Jetson Orin Nano Developer Kit stuck on boot screen after adding crontab command


I was trying to make my NVIDIA Jetson Nano (with 512GB ssd card) boot while running a custom made python script, via the “sudo crontab -e” option. The booting worked fine and the program run without issues for a while every time I rebooted the system, but then I added a command in the same crontab line (*command calling the python script* && sudo loginctl unlock-sessions) in order to automatically unlock the screen after the boot.

Now, every time I boot the system I get stuck on this screen, and none of the suggested keys work. As a matter of fact, if I try - for example - to hit ESC when the loading bar is still halfway through, the loading bar gets stuck in that position without even reaching the end as it’s shown in the picture.

Is there a way to enter at least the GRUB environment so that I can erase that crontab command? I would very much like not to flash the ssd card, or at least I would like to recover anything that’s in there before doing so.

Thank you for your help.
Edit Post

Dump the log, please:

jetson.log (34.9 KB)

Here is the log. From what I see it gets stuck at ASSERT [VariableStandaloneMm] /out/nvidia/optee.t234-uefi/StandaloneMmOptee_RELEASE/edk2/Mde)

I don’t think this is related to your script.

You can simply plug in the SSD to your host PC and acess it’s file system.

Thank you, I accessed the SSD and got the files I needed. I read (here) that this issue may be due to the amount of boots performed. Is this the case in my case? Is there a way to fix it? I am positive that I already have the latest Jetpack version (6.0), so I don’t see why this should happen.

I don’t think they are related.
Just tell me whether it’s fixed after you revert your script.

I commented the line in the crontab from the SSD card, but the issue is still there.

Then try re-flashing bootloader with this command:

sudo ./ --no-systemimg -c bootloader/generic/cfg/flash_t234_qspi.xml jetson-agx-orin-devkit internal

Sorry, but I am fairly new to this, where do I enter this command? I cannot even access the force recovery mode. Is there a way to enter this command from the outside?

Under your Linux_for_Tegra folder.

I have read the documentation you sent me, but I still do not understand what you mean by “Under your Linux_for_Tegra folder”. Do I have to access such a folder inside of the SSD? Or should I be able to find this folder inside my Ubuntu machine? Moreover, where exactly should I enter this command once I find this folder? For now, as I understood, I just connected my Jetson to my machine via usb cable (powering barrel jack is still plugged), but I’ll await further clarification before trying anything.
As I said, I am a novice at this, so thanks in advance for the clarifications.

Download the BSP on your host PC:

Exactly under Linux_for_Tegra.

I got the error message Failed flashing generic.

Here is the log from my machine:
ubuntu.log (66.6 KB)

And here is the log from the serial interface to the Jetson (from beginning of flashing to automatic booting):
jetson2.log (44.4 KB)

Is it a DevKit but not a custom board?
Dump the log only when flashing but not when it boots after flashing fails.

It is a DevKit indeed, not a custom board.

Here is the log as you requested:
jetson3.log (9.6 KB)

Oh sorry.
I didn’t notice that you are using Orin Nano instead of AGX Orin.
The error is because the wrong memory config file was used. (They are not even the same machine so of course it’s wrong.)


sudo ./ --no-systemimg -c bootloader/generic/cfg/flash_t234_qspi.xml jetson-orin-nano-devkit internal


This worked, thank you. Is it possible to know what the issue was? So that I can avoid making it happen again.

Again, thank you for your help.

I cannot really tell.
But since only the bootloader is corrupted, you don’t need to worry that you will lose your data by re-flashing bootloader.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.