Jetson AGX Orin is not properly booting after flashing OS image for R35.2.1

Hi all,

we tried to flash the following official BSP/L4T OS image for R35.2.1 from Nvidia’s website for testing our Jetson AGX Orin system, downloaded from the below link:

“ Successfully installation part was done, done unable to boot the Orin board after flashing these OS images

Attached captured log screen shots also here, please check it once.

these are the steps we followed for flashing :

sudo tar xpf Jetson_Linux_R35.2.1_aarch64.tbz2
cd Linux_for_Tegra/rootfs/
sudo tar xpf …/…/Tegra_Linux_Sample-Root-Filesystem_R35.2.1_aarch64.tbz2
cd …
sudo ./


sudo ./ jetson-agx-orin-devkit mmcblk0p1

Note: Actually we removed all usb’s (key board/mouse etc…) & camera is connected to the Jetson AGX Orin system after flashed the BSP/L4T OS image, but No change @ outcome… “ unable to boot the Orin board”

Please let us know if we miss anything here…

Thanks in Advance,

L V GiriBabu.

Please put the full booting log from serial console here, or we don’t know what’s going on.
Also, the latest version is 35.4.1, and is there any reason you have to use 35.2.1?

Also, this is the log of but not, which is of no help.

Hi Dave,

Camera vendor provide drivers for this version(R35.2.1) only

Attached log here, please go through it once…

apply_binaries.txt (12.9 KB)

cmd used for flash OS image:

" sudo ./ jetson-agx-orin-devkit mmcblk0p1 "

please let me know if I miss anything here…

L V GiriBabu.

No, can you understand what I’m saying?
Have you even checked the content of the file before posting it here?

We don’t need log for; instead, we need log for, and also the serial console log when the device is booting up.


Attached log here,

flash.txt (466.0 KB)

Is this log file u r asking right?

plz let me know if u need any info from our end…

Looks good though, then how about the serial console log?

Still, I have no idea about what you mean with this.

Jetson AGX Orin is not rebooting after flashing the Os image,
very few second Nvidia welcome screen appears in display then blank screen is getting with in few seconds… like that it behaves…

Again, we need log here. Something like Oh, the device cannot boot. or Why I'm getting a black screen? does not help at all.
Or you don’t know how to do that?

Also, are you using the DevKit fro NVIDIA, or a custom carrier board from a third-party vendor?

  1. I will share serial console log soon, we are trying to capture now…

  2. right now we are using DevKit from Nvidia only…

is this info ok for u , bcs after flashing the OS image we r getting this Nvidia screen very few seconds only, after that go to blank screen as shown above.

if this info is not relevant to you, then plz tell me how to get serial log file…

attached captured video also here for ur reference…

plz let me know if u miss any…

Attach the micro USB cable, power on the device, and run this command on your hose PC

sudo picocom -b 115200 /dev/ttyACM0

Dump what you get here.

tried with

  1. ACM0, ACM1 etc…
  2. USB0, USB1 etc…
  3. sda1,sda2 etc…

but all are getting same error as shown in the above screen shot…

plz let me know anything miss here…

Then what do you get with

ls /dev/tty*

after doing this?

Did you really power on the device?

Yes, it’s power ON only… shared screen shots plz check it once