New Jetson AGX Orin unit does not boot up

I got a new Jetson AGX Orin unit and it does not boot up.

I followed the steps given in Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer

Here are the issues…
(1) With monitor connected using HDMI-DVI cable, no screen display signal from the board seen on the monitor
(2) While connecting for headless configuration, WLAN, ethernet configuration were unsuccessful and oem-config didnot continue further. May be they are not enabled by default
(3) the board is getting intermittently recognized with headless configuration using USB too

The current status is neither connecting to a display monitor shows me the board display screen nor the screen connect to a PC terminal with USB connects to the board. In this state, the power LED shows white. During power on, the fan runs for few seconds and then goes off while the power LED stays glowing. I am kind of stuck and not sure how to progress from here.

Please help resolve these issues and help bring the Orin board up



i receommend to reinstall through sdk manager. after downloading the jetpack 5.0.2
put jetson orin in recovery mode by pressing middle button and then press& release power button

reflash the image and install all SDK components, you can also asked step to setup ssh – then connect monitor,keyboard and do configuration

This is my first time using the SDK manager, so need some guidance here…
I get a prompt that says “SDK Manager is about to flash your Jetson AGX Orin module”

In the SDK manager message prompt…here it shows “no board connected” in red where as I have connected the Orin module to my laptop using USB. Will this be color coded in ‘red’ or ‘green’ if the Orin module is connected to the host laptop and detected by the host laptop?

In the step-2 of this SDK manager message prompt, it says that “Make sure the device is connected to the power adapter, but powered off.” Does this mean that I need to switch off power at the plug point and the Orin module gets power from the USB connection with the host laptop?


In addition to my queries above, could you please clarify if there will be any indication confirming whether the module entered into recovery mode or not?

The HW configuration panel in SDK manager does not automatically recognize the Orin module and after manual selection of the Orin module in the module, the “no board connected” still is in red. Is this correct state to proceed further?

Device USB is not getting detected at all in my host laptop when connected, have tried changing the laptop as well. So, I cannot proceed with the flashing process. Like I mentioned initially, the cooling fan module should run all through when the device is powered ON. This does not happen. The fan rotates initially for few seconds and then stops. Irrespective of the software used, the cooling fan should continuously rotate as long as device is powered ON.

Please help resolve this


I followed the steps given at NVIDIA Xavier - Nvidia developer kit to get minicom logs…

:~$ ls -al /dev/ttyACM*
crw-rw---- 1 root dialout 166, 0 Aug 24 16:42 /dev/ttyACM0
crw-rw---- 1 root dialout 166, 1 Aug 24 16:42 /dev/ttyACM1
crw-rw---- 1 root dialout 166, 2 Aug 24 16:42 /dev/ttyACM2
crw-rw---- 1 root dialout 166, 3 Aug 24 16:42 /dev/ttyACM3

I find that the debug USB (Micro USB) is getting detected on my laptop but with no permissions to view/access the logs. Whereas USB type-C is not getting detected.
:~$ minicom -D /dev/ttyACM0 -8 -b 115200
minicom: cannot open /dev/ttyACM0: Permission denied

Please help resolve this booting issue.


Hi @kayccc

Could you please help me here?


When you see some error told you permission denied, maybe the first thing you should try is run it as root…

Also, you can check the device is in rcm or not by checking the lsusb command on your host.

As type-C USB port is the one that supports flashing, I tried lsusb with type-C port. And it does not show any Nvidia Corp connection. So, the device has not gone into recovery mode though I did long press-hold of the middle button (force recovery button), then press-hold of power button(left most button) and then release both the buttons together. What else should be done here?



Just want to say this again. If you board was not power on, then your need to press power button.

But if your board is already powered on, then you need to press reset button… It is not always the power button.

Also, not releasing them together, the recovery mode button is always the last one to release.

And there are only one usb type C port that can be used for flash. Please make sure you are using the correct port.

which IP address should be given in the IPv4 address field in the SDK Manager’s post-flash installation dialog, just before installing the SDK components?


You don’t need to do that for this moment. Just focus on flash the board first.

Flash OS and installing SDK could be done separately. Since you cannot boot up, I just want to focus on flash and boot issue first.

SDK is not necessary for boot up. Just as you don’t need CUDA to boot up your Windows host.

I have completed completed the flash, pending SDK components. At this point when the SDK manager prompted for installing SDK components, I clicked on the cancel button on SDK manager. and then skipped the installation. I got message on the SDK manager that the “installation of target SDK components skipped”.

Could you please guide me from here through the next steps till SDK components installation complete?



So is your device able to boot up now or not? Your topic is asking the boot issue, so we focus on boot issue.

If you want to ask new question, please file a new topic.

I donot see USB getting detected, though i can see the power LED ON and the cooling fan rotating.

Is there any monitor that you can use to test it now? Or use the serial console to check log too.

Yes, I can see the board display screen on the monitor now. dmesg logs attached,
test1.txt (80.0 KB)

Are any other logs needed?

Actually, I am not sure what you want me to say here. If you can boot up, then this issue could be closed.