Problem to put Orin (64GB version) Developer Kit into recovery state

I got Orin Dev kit (64GB version) month ago. Everything works well, until, stupid me, I removed network-manager.

Result is system in not booting anymore in graphic mode, only access is via USB cable, COM3 and putty.

No working networking so no way to restore network-manager even via command line.

I try to revert Orin to factory state. Nothing I tried works:

  • pressing force recovery and power at same time and release both, or first power then force recovery
  • close pins 1 & 2 with jumper and boot it
  • try to boot recovery partition from nVidia BIOS settings (ESC or F11 while machine starts)
  • trying force recovery mode by Linux OS commands (I tried at least three different commands)
  • try to boot machine from pendrive (only image I can get was Orin Nano, why to hell image for Orin is not findable anywhere???)

I’m desperate now, machine is not for free and I can not revert stupid action. Machine is now not usable. Seems no build-in automatic mechanism to do full unattended factory state. Excuse me, do nVidia do not imagine, that it can went wrong something with software on board and do not design user-friendly plan for such case???

I need any advice that will work or replace unit. Nothing from forums or web sites works.
please help.



Just to clarify. There seems to be one misunderstanding point…
The recovery mode is not a magic button to let the board back into normal.

It is just a hardware event to put the board into a state and you can flash your jetson from another x86 host PC…

That is why you saw some people talking about “flashing” or “sdkmanger” words in this forum because that is the tool used here to flash the board back to default state.

I mean this comment you told is just to put the board to a state “okay, it is ready to get flashed data from another host now”.

  • pressing force recovery and power at same time and release both, or first power then force recovery

Your board will only be back to work after the host PC flash image back to your host through usb connection.

I know it is not magic button, all I want to have is Orin in force recovery state. And I can not get it at all !
SDK manager steadily reports Orin is not in recovery mode, whatever I try.

What should I do, what is not already described and findable with Google, to put machine/OS in force recovery state and flash device into factory state? Or there is any script on device OS that “unconfigure” OS returning it to first ever run mode, allowing configuration of unit, please?

Best Regards,


This situation requires some check items then

  1. Which usb port are you using? Only one type C port there is the flash board

  2. Is your host PC a VM? Because VM has some issue in detecting usb device.

  3. Did the “lsusb” command on your host side see any 'NVIDIA" device? When the board is in RCM and got detected, this will be shown.

I used USB-C port that is close to 40-pin header - only this port gives me any connectivity.

When boot’ed normaly I can access Orin via COM3 exposed to my Windows 10 prof laptop, using putty.

Because my work laptop have several limitation on installing not approved by company software I use VirtualBox with Ubuntu 20.04 with all updates applied. SDK Manager detects my Orin, just when I press flash, it reports Orin is not in recovery state, and fails to flash. When I try to boot Orin from Recovery Partition or by pressing power+recovery buttons, Windows do not detect any device connected and SDK manager do not detect Orin even from very begining. Whatever I try result is same, bad as hell.

At VirualBox I can add USB device named +/- like “Linux for nVidia” or something like this, and usb devices containg some documents like LT4 readme is mounted. So surely my VirtualBox can detect usb device from Orin. But as soon I press step “Flash” this device becomes no more accesible and wanish from virtualized Ubutu until I reset Orin.


Sorry to say that but it is possible to get a native ubuntu 20.04 or 18.04 to test here?

do You mean that flashing is only possible via native Ubuntu 20.04 running on bare machine? That windows can not detect any device exposed by Orin in recovery state? And only SDK manager running on Ubuntu 20.04 or 18.04 on computer can properly communicate with Orin in recovery state? If Yes why to hell this is not stated in bold text in any documentation published by nVidia???

I need speak with my Boss to allow bring private notebook, that I will prepare, and connect it to company equipment. Hopefully he will allow.

My question was is any other way, something like “unconfigure” script, or copying filesystem from any image or place at Orin? Just plan B…


My question was is any other way, something like “unconfigure” script, or copying filesystem from any image or place at Orin? Just plan B…

If you want to learn more, then I can guide you how to debug issue. But I think it will just show the early crash in bootloader which you cannot do any configuration.

surely I want to know more. So please be my mentor.

By the way can You suggest nVidia something like "magic button that orevwrites current filesystem or allows generation secondary filesystem on other device and boot it in factory state, something that takes into account that some organizations have rules (like security Team rules that bounds everybody) that disallows some normal in other situations actions.

B.R. Jakub

Please follow this page to dump the log from “micro usb port” first after power on the board.

Your previous one was on type C port and that port can only dump kernel log and UEFI log. It is most likely your board got crash in some early stage which cannot be dumped from type C port.

do I understand properly I should boot Orin in recovery mode and then after some time I should get a log (location of log please, I do not know it).

After booting in recovery mode if it is really recovery mode Orin is not accessible in any known to me means.

B.R. Jakub

Recovery mode, in and of itself, does not modify a Jetson in any way. What it does is to put the Jetson in a mode whereby the correct USB connector is device mode, and capable of being understood by a custom USB device driver.

That device driver is appropriately named the “driver package”, and is part of the flash software which runs on a separate Ubuntu host PC (usually Ubuntu 20.04 for Orins, though it can be Ubuntu 18.04). When you install JetPack/SDK Manager (which is the GUI front end to the driver package) on the host PC it also installs the driver package and sample rootfs for you, plus sets up the sample rootfs with NVIDIA drivers. Thus you run sdkmanager with the recovery mode Jetson connected to the host PC using the correct USB cable and you are then able to flash.


do I understand properly I should boot Orin in recovery mode and then after some time I should get a log (location of log please, I do not know it).

I am not talking about dumping log when board is from recovery mode. It is correct that there would be no log when the board is in recovery mode.

My point is just to boot up the board and dump it from serial console…(not any recovery boot situation) as you said you want to find a way to recover. That was why I shared a method here to check logs first…

And there is no “location of the logs”. As I said it is from serial console, so you should open your eye and check the log printed on your minicom or other console tool on your host PC.

problems again, I connect laptop running Ubuntu 20.04 as native OS, and SDK manager detects my Orin is connected, allows me configure exact which device I will use, but that’s all, no way to get even to step one, linux option is not active, nor any other options other as selecting board. Any reason for this please?

BR Jakub

Is your Jetson in recovery mode? Think of the recovery pins as a “shift button” on a keyboard. When power is applied with recovery pin held down, or when power is reset with recovery pin held down, then it goes into recovery mode. There is no need to hold the recovery button any longer than the power on or power reset.

If the device mode (recovery mode) Jetson is connected with the correct USB cable to the host PC, then on the Ubuntu host PC you can see all NVIDIA devices on USB with:
lsusb -d '0955:'
(0955 on the left of the colon is the USB registry ID for NVIDIA, the device ID differs for different Jetsons)

Once that occurs, you start SDK Manager with this on command line:
(do not use “sudo”)

Does lsusb show your Jetson when in recovery mode? If so, then sdkmanager should be able to see it.

1 Like

no way to get even to step one, linux option is not active,

Maybe sharing a screenshot will help clarify what you saw on your side.

Hi, many warm Thanks for share of knowledge I lack. Understanding is as usual key to success. As soon as i will be back in the office I will try again. If You have more information for me to understand whole recovery forced state my joy will be limitless. Many Thanks in advance.
With Best Regards,

this will I’m not able to go to office, next week I will be then I can try to catch it.
Please do not close this topic until we got success. Many Thanks in advance.
BR Jakub

Hi here I attach screenshoot.

Device seems to be detected as in Recovery mode but there is no way to go to step 2.

Notice. SDK manager starting claims that my laptop do not have enough memory (it have 4GB) to download files in parallel mode in efficient way (I do not care how long it will take as long it will do the thing correctly :P ). I press Yes button when asked to continue. Changing settings to one file parallel do not change this grey (disabled continue to step 2).

Also selecting, on very first screen just after staring SDK manager to use local folder do not change anything.

With Best Regards


It would be better to screenshot the whole screen… but from the part of the picture, I can tell the reason you cannot run the next step is because you are using ubuntu 22.04… and sdkmanager can only flash jetson Orin with ubuntu 18.04 and 20.04…