NVIDIA Jetson AGX Orin Dev Kit Initial Setup Issues

Hi, I am new to Jetson products so this might be a dumb question but I’ve been stuck on it for a while and can’t figure it out.

Essentially, I have a new Jetson AGX Orin developer kit and I can’t get it running. I have tried following Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer

With the display attached instructions, it shows up the nvidia’s logo screen and then goes black after showing no video input. According to instructions, on first time boot, its mean to take you through a setup but it did not prompt me to do that after countless attempts. I am not sure what i am doing wrong? The screen mentions below the big nvidia text “Press escape for boot options” which when does not seem to do anything (i dont think the keyboard even turns on at that point).

So then I tried the instructions for the headless configuration to try to get it running. It mentions “On your computer, use a serial terminal application to connect via host serial port to the developer kit.” I have tried to google alot but I can’t find how to do that (I am new to this). On windows, nothing new would show up in device manager after plugging in the usb to usbc cable (usb on computer side). Then I found out that I need to do something in a software called PuTTY? but I dont know what the Serial Line COM port should be (which I was trying to find in device manager). I tried on linux as well but nothing new would should up after doing “dmesg | grep --color ‘tty’” before and after plugging in the usb.

The display attached version of setup seems simpler to do, but If that does not work, the other option would have to do I suppose. I havnt really dealt with alot of manual serial communication in the past, so I would really appreciate if the replies keep that in mind and provide detailed instructions!

I am not sure what I am doing wrong. I’d appreciate any help with this issue! I am open to getting in contact and maybe even going on a call or something similar for faster resolution. Thank you in advance!

Hi shivamkataria1000,

What’s your Linux distribution?
Do you have standalone Ubuntu 18.04 as your host PC?
It is recommended host OS to develop Jetson and also flash the board.

You could refer to the following instruction to setup serial console for Orin devkit.
NVIDIA Jetson Orin - Serial Console
For Orin devkit, it uses Micro-USB port for serial console. (/dev/ttyACM0)
In Windows, just re-plug and check which COM port showed up in device manager.
In Linux, you could use the following command to check all tty peripherals.

$ sudo ls /dev/tty* 

I am on a Ubuntu 20.04 work laptop, so changing versions for it isn’t feasible.

I did try on both the ubuntu machine and my windows machine, but neither of them showed that it as plugged in (no com ports showed up in device manager, and no additional tty showed up in ubuntu). When I plug it into ubuntu, a message shows up saying “Connection failed: activation of network connection failed.” (not sure if thats just a random error or related to this).

Ubuntu 20.04 will work on the JetPack/SDKM 5.x+ releases (L4T R34.x+). Earlier releases would use 18.04, which also works with newer releases.

If you connected the Jetson to another system, and that other system noticed a virtual network device on the USB, then the implication is that the Jetson is fully booted. You wouldn’t see a network device on a recovery mode Jetson, and on a regular boot this won’t exist unless Linux loaded and reached at least the multi-user.target stage (command line console). You might have nothing more than a GUI problem.

On the Jetson, can you reach a text console with CTRL-ALT-F3 or ALT-F3?

That network connection failed might actually just be a random unrelated error because it has shown up even when the jetson is not connected.

I am not able to reach a text console. On bootup, it shows a screen with the Nvidia logo and then no video output. Keyboard does not seem to work during this period either. I will try to upload a video if it lets me.

So far, I have not tampered with the jetson except for what Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer this guide said and the suggestions made on this forum.

The above video is what it shows when i connect power, keyboard, mouse and display port

The video below is with power and usbc to usb connected to a windows laptop, where nothing is being detected in the device manager.

From your first video, it looks something wrong after UEFI.

From your second video, it seems you are using TypeC port (this is for flash), but the serial console log is coming from Micro-USB port.

Please use Micro-USB port of the devkit for serial console log, and provide us the log for further check.

Ahh, I was using the type C port since that was what the guide specified. As for the UEFI, I am not sure how to fix that. By the way, was there something to be flashed onto the Orin beforehand?

After using the micro usb port, and running sudo dmesg --follow, and connecting the usb to the laptop, the new text on the terminal was:

[ 7518.103505] usb 1-3: new full-speed USB device number 21 using xhci_hcd
[ 7518.231517] usb 1-3: device descriptor read/64, error -71
[ 7518.467514] usb 1-3: device descriptor read/64, error -71
[ 7518.703503] usb 1-3: new full-speed USB device number 22 using xhci_hcd
[ 7518.831516] usb 1-3: device descriptor read/64, error -71
[ 7519.067515] usb 1-3: device descriptor read/64, error -71
[ 7519.175578] usb usb1-port3: attempt power cycle
[ 7519.587505] usb 1-3: new full-speed USB device number 23 using xhci_hcd
[ 7519.587629] usb 1-3: Device not responding to setup address.
[ 7519.795630] usb 1-3: Device not responding to setup address.
[ 7520.003505] usb 1-3: device not accepting address 23, error -71
[ 7520.131513] usb 1-3: new full-speed USB device number 24 using xhci_hcd
[ 7520.131630] usb 1-3: Device not responding to setup address.
[ 7520.339630] usb 1-3: Device not responding to setup address.
[ 7520.547503] usb 1-3: device not accepting address 24, error -71
[ 7520.547586] usb usb1-port3: unable to enumerate USB device

On windows, a notification pops up saying USB device not recognized and in device manager, it shows up as unknown usb device (device descriptor request failed).

I tried the sudo dmesg --follow again after a reboot, but the same story. I have attached a screenshot below (usb was connected after the red line)

So, could you see the serial console log at this moment?

You could just use Ubuntu PC to debug and flash.
Make sure which port is in use with ls /dev/tty* and use minicom tool for serial console log.

I was unable to get the serial console to show up.

On ubuntu, after plugging in usb to micro usb (usb on laptop side), /dev/ttyACM0, /dev/ttyACM1, /dev/ttyACM2, /dev/ttyACM3 show up. None of them seemed to work on minicom. Also, the 4 mentioned ACMs, were a little finicky with sometimes not showing up, so I had to replug things a bunch of times.

Since this is my first time dealing with minicom and serial com like this, I’ll put screenshots incase I am making a dumb mistake.

The image below is the tty* ports that show up

The image below is the settings for minicom that I used (this instance is for ACM0, but I have also tried the rest)

The image below shows the result of what all the ACM ports show. It stays on this screen and nothing shows up. At the bottom, it shows offline. (I dont know why it shows the year as 2019 lol)

Edit: the finicky issue seemed to be with the cable i was using but that is now good

Now I am able to see the log. Its quite long so I have attached the txt file below.
error (copy).txt (77.5 KB)

What would be the next steps from here? Also, it is asking me for a username and password. is there a way to reset it?

You could try to set “Hardware Flow Control” to “No” to interact in the console.

There’s no significant error from the serial console log.
Is it still black on your monitor at this moment?

It seems no oem-config setup at this moment, you might set username and password before.
Please use SDKM with Ubuntu PC to re-flash the board and reset them.

Is it still black on your monitor at this moment?

Yes, the screen still ends up turning black after the Nvidia screen

I am now following Jetson AGX Orin Developer Kit User Guide - Two Ways to Set Up Software | NVIDIA Developer’s SDK guide however, it mentions: " When flashing is done, the Jetson developer kit will reboot and boot into the L4T BSP.
Yon can complete the OEM Config as described here ."

but the link is broken. Where and how do I setup OEM config from?

Following the guide mentioned above, I am encountering issues. It gives an error when I try to flash it. I am also not sure what they mean by connect the power type C cable but powered off, the pc would just not detect it then? I tried powering it off by holding the power button. and then did steps 4, 5 and 6 which turned it back again. What does step 3 mean exactly? Edit: I have also tried keeping the usbc plugged in but the outlet not being plugged in to the wall on the other end but that did not work either, incase that is what the guide meant.

Also, the guide says to “Ignore 7, OEM configuration” and to do it after flashing. Is there a reason for that, or can i just do it in this step like shown in the screenshot, since the guide’s OEM config link also doesnt work.

Please refer to the following link to check if the board enter force recovery state.
Quick Start — To Determine Whether the Developer Kit Is in Force Recovery Mode

From your screenshot of lsusb result, you are in force recovery state with 7023 for Orin devkit.

The following is the full instruction to use SDKM to flash the board.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

On Step 2, it says “Target HW image location can not be changed since it is already installed at {location}. To change the location, please uninstall the target image first.”

I had previously installed at that location, however that location no longer holds anything so I am not sure why it wont let me change it. The “change” is greyed out.

Also, to confirm, once the jetson is in force recovery mode, flashing can simply happen instead of anything to do with power like the guide is saying? The step 5 from the guide you shared, in manual setup, the instructions on the screenshot say “make sure the device is connected to the power adapter, but powered off.” I am not too sure what that means like I described in my previous message.

Could you show the screenshot of the message on SDKM?

Step 5 is just the instruction to guide you enter force recovery state. If you could use lsusb and see 7023, then you’ve already been in this state.

Sounds good.

the target location is empty. I have tried deleting the folder as well, but the change option has been greyed out.

But thats fine, since it created that directory.

Before flashing, it asks me what jetson AGX orin I have (different gb options). Is there a way for me to check which one it is?

I have been successfully able to flash it, and GUI on the monitor seems to be working well too. Thank you for the support provided! The above question is still a mystery tho since it seems like it worked but Im not sure if selecting the wrong option leads to something else or not.

so good to know this.

I think that is just the location to store the BSP packages.
It would allow you to select which directory you want to use for the first time.

In this step, just checked “I accept the terms and conditions of the license agreement.” and press continue.