Jetson AGX ORIN won't boot up


I just received my Jetson AGX Orin Dev Kit, I connected the DP and the peripherals and it is not booting up. I was following the getting started video Getting Started with the NVIDIA Jetson AGX Orin Developer Kit - YouTube and I can’t get to boot up the Jetson AGX Orin.

I tried to connect with the serial port and it is not showing anything on the screen either. Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer

Hi sirkilly,

Are you using DP-monitor directly connected from your DP port on the devkit?

What host PC OS you are using? (Linux, Windows, MacOS…etc)
You could use Micro-USB cable to check UART console log at /dev/ttyACM0.


I tried both ways. I first tried the DP-monitor directly and the Dev Kit turned on but nothing was showing on the monitor.
I used linux, I tried the console log at /dev/ttyACM0 with the USBC to USB A and it got connected with screen but it wasn’t showing anything either. When I connected the USB C to my pc, it showed a mounted partition with l4t but nothing else.

Do you use any application for viewing console on /dev/ttyACM0 (e.g. putty, minicom…etc)?
NVIDIA Jetson Orin - Serial Console

You could refer to the following link to re-flash the board with SDK Manager.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation


It tried both minicom and screen and still no serial output.

I downloaded the rpm version of the sdk manager, it detected the Target Hardware as Jetson AGX Orin Modules but the Target Operatiing System Linux says it is not available, it says “No available releases for host OS. Fedora36.” It seems I need to have a Ubuntu OS?

There is also an offline mode, is there a place where I can download the Jetpack SDK for AGX orin?

It’s recommended using Ubuntu to develop Jetson.
NVIDIA SDK Manager | NVIDIA Developer

Jetpack SDK could be downloaded through SDKM.
Or you can download in R35.1 Release - Driver Package (BSP)
Jetson Linux 35.1 | NVIDIA Developer

The SDKManager doesn’t accept the file in offline mode, I will try to use another PC with Ubuntu.

JetPack/SDK Manager is just a GUI front end to the flash software. In the past I’ve manually downloaded and installed the “driver package” and “sample root filesystem”, and flashed on command line (this was many Fedora releases past though). There are some advantages to using JetPack/SDKM though, and it is advised. However, the basics for command line:

  • URL for L4T releases (which is what actually gets flashed…Ubuntu plus NVIDIA drivers makes L4T).
  • Unpack the “driver package” as a regular user. This creates a “Linux_for_Tegra/” subdirectory.
  • Unpack the “sample root filesystem” into “Linux_for_Tegra/rootfs/” using “sudo”.
  • From “Linux_for_Tegra/” run “sudo ./”. You’re now ready to flash and don’t need to repeat the above.
  • Optional: Run “sudo ./tools/” to pre-create the login account (this name/pass will be installed to every flash automatically if this step is performed).
  • With the Orin in recovery mode and attached correctly:
    sudo ./ jetson-agx-orin-devkit mmcblk0p1

This will not add optional packages. This is normally done after the Jetson automatically reboots upon completion of flash and first boot account setup. You should be able to add those packages using apt on the Jetson after you’ve booted and updated.

Note that if you get to a stage where most of the work is done, and you don’t want to repeat the updates and additions of packages, so on, you could clone, and later flashes would use the clone and all of that would be complete. You just put the clone in the right place and tell command line flash to “reuse” the image and not generate a new image.

It would still be easier if you had an Ubuntu 20.04 boot (e.g., add it as a boot option to the existing Fedora, but beware it takes a lot of disk space).


Thanks a lot, it helped me to flash the image.
I ended up using a VM with Ubuntu 20.04 ( I tried with 22.04 but there is no image on the SDKManager).
I finally flashed onto the Jetson AGX Orin and got a login page.

I got a few questions if you can help me, how to install all the dependencies for nvidia-jetpack, the installation stops and launches errors for all of the packages.


Hi sirkilly,

You could use apt (is a command-line tool to manage packages) to install nvidia-jetpack and related dependencies.
Please refer to the following link for details about installing JetPack compenents
Getting Started with Jetson AGX Orin Developer Kit | NVIDIA Developer: Step 2 - Install JetPack Components
$ sudo apt update
$ sudo apt dist-upgrade
$ sudo reboot
$ sudo apt install nvidia-jetpack

If you have other questions about installing Jetpack, please open a new topic for discussing.

Hi @KevinFFF,

I managed to flash the Jetson Linux onto the Jetson AGX Orin (Jetpack 5.0.2 Rev. 1, should I flash the Runtime one?) It booted up and I logged in.
But I’m unable to install the nvidia-jetpack, either through the SDK or apt.
I have a myriad of different dependency problems that arise after:

and after I got the following messages.

 The following packages have unmet dependencies:
 nvidia-jetpack : Depends: nvidia-jetpack-dev (= 5.0.2-b231) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And when I tried to install nvidia-jetpack-dev

sudo apt install nvidia-jetpack-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-jetpack-dev : Depends: nvidia-nsight-sys (= 5.0.2-b231) but it is not going to be installed
                      Depends: nvidia-tensorrt-dev (= 5.0.2-b231) but it is not going to be installed
                      Depends: nvidia-cuda-dev (= 5.0.2-b231) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any idea on how to approach this?


It seems there is something wrong with the Jetpack 5.0.2 Rev 01.

The easiest way to do the following is to have a Ubuntu 20.04 (Doesn’t work with Ubuntu 22.04) and install SDKManager.

While in Recovery Mode (Push and hold recovery button and then push the restart button) connect with the UBS-C to the Host Ubuntu 20.04.

In the Host Ubuntu 20.04 open SDKManager and flash JetPack 5.0.2 Runtime Rev 01.
Then, install nvidia-jetpack

For some reason JetPack 5.0.2 Rev 01 has many dependencies issues, only Runtime works.

Thanks to all.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.