Unable to deploy jetson sdk components from sdkmanager

My team has been trying fruitlessly for days to get one of our AGX Orin development kits updated to Jetpack 5.0.2 on Jetson-Linux 35.1 using SDKmanager 1.9.1. All attempts have failed due to unmet dependencies.
We have tried using Ubuntu 18.04, 20.04, and the respective docker images with the same result.

We are able to flash the jetson-linux image without issue, it’s the SDK installation that fails.

We have referenced the topics below

The commands we are issuing: (docker)
docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ -v /dev:/dev -v /media/$USER:/media/nvidia:slave --rm sdkmanager --cli install --logintype devzone --product Jetson --version Runtime_5.0.2 --targetos Linux --host --target JETSON_AGX_ORIN_TARGETS --flash all --license accept
docker run -it --privileged -v /dev/bus/usb:/dev/bus/usb/ -v /dev:/dev -v /media/$USER:/media/nvidia:slave --rm sdkmanager --cli install --logintype devzone --staylogin true --product Jetson --version 5.0.2 --targetos Linux --host --target JETSON_AGX_ORIN_TARGETS --flash all --additionalsdk ‘DeepStream 6.1.1’ --exportlogs /var/log --license accept

Additionally we are unable to issue the install in a single session as sdkmanager reaches the point of accepting user sign-in and fails to move forward (no errors, just no progress) :

My team in Italy is reporting identical results, we don’t know how to proceed at this point.

Hi manbehindthemadness,

We would recommend using SDK Manager on a standalone host PC with Ubuntu18.04 instead of using VM or docker.

SDK components should be installed after oem-config setup (time-zone, username, password…etc) finished. You have to finish oem-config through DP output to a monitor first and the SDK component installation would be processed.
Or you could install through running the following command on device:

$ sudo apt-get update
$ sudo apt-get install nvidia-jetpack

We actually solved the issue by switching from 18.04 and going with 20.04. Systems are up but are giving us hell compiling opencv; however, I will open another topic regarding that

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.