Jetson AGX Orin with Jetpack 6.0 upgrade failed

Hi,
I have a Jetson AGX Orin devkit 64GB. And today I want to update to Jetpack 6.0.

Tool: SDK manager 2.1.0.11669.
Host machine: ubuntu 22.04

Everything go smoothly from downloading files to building process. To the state of rebooting the jetson, After the NVIDIA splash screen, it shows nothing.
I tried to reboot jetson. It then boot up to ubuntu desktop, and setup. But the log is really strange. After some loading, it show the blank desktop.


Below is the full log exported from SDK manager. It stated that it could not connect to jetson’s ssh server.

SDKM_logs_JetPack_6.0_Linux_for_Jetson_AGX_Orin_modules_2024-05-13_21-56-46.zip (244.3 KB)
Thank you!

Check your network setting (VPN, firewall,…) to make sure the device can ssh root@fc00:1:1:0::2

Have you done this?

Ok I check the router, it is a home network so I pretty sure that it not blocking anything. I connect jetson to router using ethernet cable, and the USB-C serial port to host machine. All connect to the same router, same network.

Then I run the ssh root@fc00:1:1:0::2 command and it’s timed out. So I check the network address of the jetson devkit


It’s seem that the jetson does not have any address related to fc00:1:1:0::2. The closest one is fe80::1.

What am I doing wrong here?

Are you using the right USB-C port for flashing?
The one next to the 40 pin header.

Or try this method instead:
https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/SD/FlashingSupport.html#flashing-to-an-nvme-drive

Yes, I checked and use the right port - the one next to 40-pin header before plug into the jetson. I also have a SSD drive attached to jetson. Booting from eMMC or external SSD drive not working right now.

For more detail, here the current behavior of the jetson. I power it on → booting (either from eMMC or external SSD), when it show the ubuntu’s desktop screen it will enter the oem config. After the step of entering username and password, it runs some setup and the setup window is gone. Leave it the blank screen. At that time, I can start a terminal session as root, user I just entered is not created (as you can see like the image I sent above). I have tried to start the ssh service, it start successfully but my machine cannot connect to it using ssh (with the address obtained from the command show in the image above). It kind of struggling in some state that I don’t know.

I tried to flash several times with both eMMC and SSD, but the same result happened. Each time it takes couple hours so it really time cosuming.

I haven’t with flashing using command line, may be I will try that. But I have a small question: How does the flashing script get this address - fc00:1:1:0::2?

Oh, it’s a known issue on JetPack 6 GA with OEM config.
Please do this before flashing:
https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/SD/FlashingSupport.html#skipping-oem-config

Or set user accounts in SDK Manager in advance.

This time, after using command line on host machine (command sudo ./flash.sh jetson-agx-orin-devkit internal) to flash again. I look at the boot, It go from 36.2 to 36.3. So the kernel is updated. OK!

In step install SDK component, it cannot connect to jetson via ssh.
I have unplugged the ethernet cable, leaving only the USB-c serial port. And for sure on my host machine, I turn off wifi and ethernet as well, leaving the serial port as the only connection. I checked the proxy and make sure to disable the proxy as well.
I try enter both my created user and root user but no luck.


The jetson is still the blank desktop after running some configuration.
On jetson I check the ssh.service and it showing error

All of these procedures I flashed to eMMC. I will try to flash to SSD today to see if error still occur or not.

This time I haven’t run the skip-oem-config. Maybe I should run the ‘skip-oem-config’ as you mentioned before?

How can you download SDK component when you don’t even have Internet connection on your host PC…

There should be no difference.

YES.

How can you download SDK component when you don’t even have Internet connection on your host PC…

Obviously, I disconnect the wifi after the download phase completed and start flashing,

Now I’m at step of installing jetson component and it show error like below

Jetson is currently black screen with blinking cursor. I cannot enter the command sudo apt-get update && sudo apt-get check like in the message

This is the log I export after try many times and still fail.
SDKM_logs_JetPack_6.0_(rev._1)_Linux_for_Jetson_AGX_Orin_modules_2024-05-17_00-05-20.zip (213.0 KB)

I don’t think we have any documents telling user to do this.

This is just a simple trick to isolate some factors to make sure when I debug, it is not the cause. I can connect to network when needed, not a big deal. The concern is jetson cannot install sdk component. As you can see in the image, the internet connection and physical wiring is NOT a problem.
The message shows that the the apt repository. What could be the cause and how can we fix it? Do you have any suggestion?

Thank you and much appreciate for your patient!

It shows APT repo check failure, so of course it’s related to your Internet connection.

You will see in the image, the sdk manager stated clearly that the internet connection is ok. I personally ssh to jetson and check, both local network (via USB-C) and internet (ethernet port) is ok. The jetson module can ping to some hosts like google, nvidia,…

Again if you look in the image at the bottom, you will see the message
sudo: /etc/sudo.conf is world writable
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set
This propably the cause. Because I cannot execute command with sudo. In ssh command line, the response show exactly this. Just to be clear, the network is not being blocked by proxy or anything else.

I cannot execute the command sudo apt-get update or any command require sudo.

So you are saying that you flash your device with our default BSP, and you cannot use anything require sudo on the device?
I still have no idea what you are doing now. That should not be the case.

Have you done this or not?