Jetson can't boot after jetpack update

I know it’s very similar to: topic|help/247392, but the difference is the last line:
EFI stub: Exiting boot services and installing virtual address map…

Anyway I tried solution from linked topic (press recovery button and unplug power), but it didn’t worked. Should I leave it over night to complete this “virtual mapping”?
And second question,
if it won’t boot, how can I write fresh system? Thanks.


Basically you can reflash your board with sdkmanager at anytime.

Honestly, I am curious about what did you do to hit current situation.

Hi, I was following this guide, maybe I misspelled the version…? I had jetpack 5.0.1 and installed 5.1.2, I had some errors during the upgrade, but when I checked jetpack version it showed 5.1.2, but after ‘sudo reboot’ boot problem appeared.

I downloaded sdkmanager on my personal amd linux machine, but the process freezes on 31.25%

Do you know any guide how to flash new system step by step on Orin? I was following this one, but I can’t set the board in recovery mode with buttons.

Are you using the official Developer Kit by NVIDIA?
Is the device detected by the host PC with lsusb?

Dump the log here.
We don’t know what happened with just the process freezes on 31.25%.

Yes, the official one.

My host isn’t detecting the board. I tried different button combinations, plug, unplug, different ports and I am using original cable.

I am trying ctr+v logs here, but I get error that new users can add only 4 links.

Then just post the log as a text file here.
Or SDK Manager can export the log as a ZIP file.

Did you put the device into force recovery mode correctly?

I probably can’t put the board into recovery mode.
I tried advice from this topic , but when I’m clicking the buttons, even LED is not flashing.
I have connected only USB-c cable to port next to 40pins. Should I connect power supply to the second USB-c?

Of course you need the power supply…

Ok, funny mistake. I thought power is coming via my host machine. Anyway the sdk still can’t flash:( Jetson is in the recovery mode, host sees it, but process breaks during installation. I attached the logs. (113.6 KB)

It’s a known issue that has been around for a while…
We are still debugging it.

Currently what we can suggest is that avoid virtual machines, use Ubuntu 18.04 instead of 20.04, try with a different USB cable/port, or the following command:

sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend
1 Like

Command didn’t help, different cable didn’t help. Finally I downgrade my ubuntu to 18.04 and it worked! I recovered the system installed the new Jetpack. I can connect with it via cabel
(ssh XYZ@, but how to connect with the board via wireless ssh? I tried find address with ip a but it seems that ssh is turned off?

I’m not sure what you mean with wireless ssh.
Do you have eth0 enable on your device?

I mixed up the concepts… I just want to connect Jetson to wifi, but wlan0 seems to be turned off and I have problems to configure it via terminal. Do you know if system from sdkmanager is headless or it is desktop version?

You should have access to the GUI desktop, and enable the WiFi card with it.
Or in case you want to do it with terminal, check this

I configured it with GUI, problems solved. Thank you very much for your help:)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.