Jetson Orin AGX Devkit failure

I have been unable to use the 5.1 or 5.1.1 SDKs to flash a new image onto my jetson-orin-agx-devkit. As best I can tell one of the components is not flashing properly. Is there a good workaround for this?

Here are the results from SDK Manager running on a clean Ubuntu 20.04.6 machine.
orin.log (8.6 KB)

I have tried several other things (running directly, USB boot, etc) but none of them fare any better so far.

Hi mcallahan2,

Are you using the devkit or custom board for AGX Orin?

Could you flash the board and boot up successfully? Or you just failed at installing SDK components?

09:09:44 INFO: NVIDIA Container Runtime with Docker integration (Beta) - target: Found file /home/mcallahan/Downloads/nvidia/sdkm_downloads/libnvidia-container1_1.10.0-1_arm64.deb with correct checksum, skip downloading.

The log from you just showed few messages.
It seems you are using docker for SDK Manager.
Please help to get a standalone Ubuntu 18.04 or 20.04 as your host PC.


That log is from SDK Manager on vanilla Ubuntu 20.04.6 updating a jetson-agx-orin-devkit.

At this point I have tried far too many different things. I have tried Ubuntu 22, Ubuntu 20, Ubuntu 18 on different machines. I have swapped cables. I have tried SDK Manager, the docker image, and running the scripts directly. I have also tried the last three releases. These all result in approximately the same error except for one case that I can get working.

(Note that I got to this point because I updated the Orin via apt from 5.1 to 5.1.1 and on the next reboot the update flashed something resulting in a brick.)

So it turns out that Ubuntu 18 with SDK Manager can successfully flash the Orin with the 5.1.1 SDK. It took several tries but I swapped to the better USB cable and it seems reliable now. It takes about an hour to flash which leads me to believe Ubuntu 18 works because it’s slow and there is something wrong with this devkit. (I also turned off the SDK components so that the installation would be faster to get it down to an hour and increase my odds of completing the operation). I have not yet tried to update via the command line with on this older machine but I am optimistic that this will work.

What might be going wrong here that I cannot simply flash the devkit with SDK Manager on Ubuntu 20.04.6? The obvious ‘try a different orin’ is out as I only have the one available at this time.


I’m glad to hear you found a way available to flash the board.

It should work with standalone Ubuntu 20.04 host PC.
There are many reasons causing flash fails, it’s hard to tell you what’s root cause in your case. We would need both the flash log from host and serial console log from the board to know what’s going on and do further check.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.