Jetson AGX Orin Flashing Issues, even in 18.04

Hi all,

I am hoping to find some help here with a topic that was once already discussed in this thread (which is closed already):

I am still having issues trying to flash the AGX Orin 32GB systems, even when using Ubuntu 18.04 (which seems to have solved the issue for others).

I am using a Toshiba host laptop (toshiba satellite l755-1d6) which runs 18.04. directly installed on the laptop.

Everything seems to work fine, until the flashing starts…right before, it recognizes the AGX Orin perfectly (shown in the SDK manager itself and also via lsusb). But suddenly, when the flashing would start, it seems to throw this error message as if it has lost connection or has some trouble with the USB connection (it is plugged in on USB 3.0 on the host).

As I’ve also read that sometimes the pre-config of a user could make troubles, I also already tested it with the runtime configuration option, but that didn’t make it work as well.

I attached screenshots of all the steps in the SDK manager and also attached the log from right after the issue happened.

I hope that someone can finally figure out this issue as it seems that I am not the only one here (although it seems like for most people it solved the issue when using 18.04 instead of higher versions - unfortunately not for me…).

Thanks a lot beforehand,

SDKM_logs_JetPack_5.1.1_(rev._1) (80.3 KB)

Hi david.berger,

Are you using the devkit or custom board for AGX Orin?

11:37:03.471 - info: NV_L4T_FLASH_JETSON_LINUX_COMP@JETSON_AGX_ORIN_TARGETS: [   0.9519 ] Kernel DTB used: None
11:37:09.163 - error: NV_L4T_FLASH_JETSON_LINUX_COMP@JETSON_AGX_ORIN_TARGETS: [   1.6293 ] ERROR: might be timeout in USB write.
11:37:09.163 - info: Event: NV_L4T_FLASH_JETSON_LINUX_COMP@JETSON_AGX_ORIN_TARGETS - error is: [   1.6293 ] ERROR: might be timeout in USB write.

Do you have other standalone Ubuntu 18.04 host PC with the same issue?

Have you also tried to flash with script?

Hi @KevinFFF,

thanks for the reply.

I am using the AGX Orin with an Auvidea Carrier Board (X410). I am also in contact with them in parallel for the case their board is the reason for the behaviour.

I tried it with another 18.04 host machine a while back and had the same issue.

No, I haven’t tried flashing it with a script yet, as I am not familiar at this point about how to do that.

If you are using the custom carrier board, you should use the custom BSP package with flash script instead of SDK Manager.
SDKM will download the BSP package for the devkit, which should be different from the custom BSP package due to board design.

After you get the BSP package from the vendor, you could refer to the following instruction to setup and flash it with script.
Quick Start — To Flash the Jetson Developer Kit Operating Software

Hi Kevin,

it had been two issues: First of all, there was a problem with the USB cable, the connection was fine after switching to another one. Secondly, I was exactly as you described: I thought I could just use the normal flashing method, but then realized by talking to Auvidea that they have their own flashing script for a different kernel etc.

Thanks for help!

So great to hear this.

Yes, you should follow their instruction to use flash script for the custom carrier board. The custom design should be included in their script and packages.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.