Cannot flash Jetson AGX Orin (JetPack 5.1.1)

I have a Jetson AGX Orin, initially with Jetpack 5.0.1 DP. After running apt dist-update and rebooting the board, I can’t access it through ssh anymore when using an ethernet cable. It also doesn’t display video when connected to a monitor.

I can access the terminal through the micro USB port and the OS seems to be working. I can’t ssh into the board using the usb C port as well.

The board has a nvme ssd attached, so I was able to recover all my files. Now I’m trying to re-flash the board with Jetpack 5.1.1, but without success.

Only when in recovery mode, I can see the usb port with the command lsusb:

Bus 003 Device 008: ID 0955:7023 NVIDIA Corp. APX

Nothing shows up on the uart port when I try to flash the board.

I’m sending the SDK logs and the outputs on the uart when I reboot the board.

uart_log_boot.txt (98.7 KB)

SDKM_logs_JetPack_5.1.1_(rev._1) (87.5 KB)

My host computer has Ubuntu 20.04.6 and it is able to flash another Jetson Xavier NX I have.

Thank you


A lot of users have encountered this USB timeout issue when flashing their AGX Orin, but the root cause varies case by case, and there’s no single universal solution to this issue. Can you try different USB cables, USB ports, or in case you have another Ubuntu PC? Also, Ubuntu 18.04 seems to be more stable than Ubuntu 20.04 empirically.

If all of the above methods do no work, give these posts a try:

I’ve tried many usb cables and also tried to flash using another laptop with ubuntu 18.04, but the results are all the same.

Something interesting is that none of the jetson’s usb ports seem to work. While connected through the micro usb (using minicom), I tried to attach usb devices, such as a mouse, but they didn’t show up on the jetson’s lsusb. I was able to connect using the jetson’s wifi though.

Any idea?


I just noticed that you said that there was no log showing up in UART when you flashed the board.
Then can you try these commands and share the dmesg log on your host?

Orin AGX devkit’s micro usb port is actually a UART port with UART-USB adapter connected…

So any usb device connected to it won’t have effect… this port is only for dump log(miniocm).

Just want to confirm again. Is this micro usb port able to print any log when you conduct the flash process?

Here is the dmesg log:

dmesg_host.txt (110.6 KB)

And that’s correct, there was no log showing up in UART when I tried to flash the Jetson device.

Regarding the usb devices I mentioned, I believe I didn’t explain it well. I connected my host computer to the Jetson through the UART using minicom. That allowed me to connect to my user and access the terminal in the Jetson AGX Orin. I connected a mouse to the Jetson USB A port, and ran lsusb in the Jetson’s terminal (through minicom). The usb device (mouse) didn’t show up in the Jetson’t terminal (using lsusb), that I was accessing through minicom. Actually, lsusb was empty.


It is normal if the situation happened in your previous state, where you board is totally messed up at that moment.
That is different issues and not related to flash.

Could you try to flash emmc instead of nvme too? I don’t think it would work, but just want to double confirm.

I tried both emmc and nvme using the SDK manager and got the same result without any log in the UART

Currently you can only try other host machines or other cables.

We are still looking into your log.

Hi @MatzzV

Please help enable these on your host machine before the flash process.

echo 8 > /proc/sys/kernel/printk
echo ‘module usbcore +p’ > /sys/kernel/debug/dynamic_debug/control
echo ‘module xhci_hcd +p’ > /sys/kernel/debug/dynamic_debug/control

After flash starts, share the kernel log with dmesg command.

Here is the log. Please let me know if this is the correct log you need,
dmesg_host2.txt (17.8 KB)

Hi @MatzzV

Please try to disable autosuspend on your host PC and see if the flash works.

sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend

It worked! Thank you so much, @WayneWWW @DaveYYY !!

1 Like

Hi @MatzzV,

We are glad to hear you resolving the issue.
Could you help to get the following information of USB devices with the failure setups?
We want to do further check with this issue.

  1. Connect the Tegra device to host the customer used to flash the device

  2. Put the Tegra device into RCM

  3. Get the USB information on the host

  4. Run the following command and share the result for us

$lsusb && lsusb -t && lsusb -v > ll

Sure, I’m in a conference out of my country now, but I can send you the results once I get back next week.