Jetson AGX Orin 64GB devkit flash issues

Hey guys,
Did I really managed to mess up entirely my Jetson AGX Orin 64GB devkit?
It was running well, when I tried updating the apt sources from 35.4.1 to 36.2… then I was stupid enough to try:

apt update && apt upgrade

… and my device stopped responding after a while… I did a coldboot, but it seems it doesn’t boot. Then here I am trying to reflash it using the SDK Manager, but always fail with:

[   0.0265 ] File rcm_state open failed
[   0.0268 ] ERROR: failed to read rcm_state

USB autosuspend is disabled! Now I’m stuck… The ‘Recovery Mode’ looks like it works, but it kind of doesn’t… When I boot in Recovery Mode (RCM) I can see the device as APX on my machine:

[ 5558.684721] usb 1-3: new high-speed USB device number 19 using xhci_hcd
[ 5558.835247] usb 1-3: New USB device found, idVendor=0955, idProduct=7023, bcdDevice= 4.01
[ 5558.835265] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5558.835273] usb 1-3: Product: APX
[ 5558.835279] usb 1-3: Manufacturer: NVIDIA Corp.

However when manually try the command to check it’s uid… it says it is not in RCM state:

$ sudo ./tegrarcm_v2 --uid
File rcm_state open failed
ERROR: failed to read rcm_state

Anyone with clever ideas how to fix this?

Put the full log. Don’t crop it yourself.
PLEASE.

ERROR: failed to read rcm_state

This is expected and nothing to panic about.

Sorry, here is the log.
SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_AGX_Orin_modules_2024-01-25_11-19-53.zip (77.0 KB)

[ 0.2515 ] Sending bct_br
[ 0.2517 ] ERROR: might be timeout in USB write.
Error: Return value 3

The same question has been asked many many times.
Please make sure you unplug & plug in the flashing cable, and put the device in recovery mode again.
Maybe also reboot your host PC.

If you are referring " Q: I get a USB timeout error during flash Orin. How to resolve that?"… this topic I’ve created is the last step from the answer: “If USB timeout is still there after above commands, please file a topic to forum and let moderator help check.”

Have you done all of this?
Other things like find another host PC/use Ubuntu 18.04 instead of 20.04 may also help.

Not easy to find other host for test… However I’ve tried wife’s surface tab and errors are the same… I think there is something wrong with the EFI boot on my device… it is not properly booting the device. I’ve hooked it to a USB keyboard and TV… I’m able to access it’s BIOS/EFI menu… There is option to boot from file and using that tool I can see my files and my home dir are still there, but it doesn’t boot properly. Is there any recovery USB image I can use to try and fix it?

I don’t think you can revert the whole system from 36.2. to 35.4.1 by manual file copy.
The only way to get around this is to find a host PC that does not mess up with the USB auto suspend issue.

Man I’m pretty sure it is not the autosuspend that messes up… If that’s the case it would mess up after a while not immediately after I plug the device in. I’ve disabled the autosuspend completely on all devices, VMs, docker containers used so far… They all show the same. Even the tablet (different physical machine) showing the same error.
I’m also trying manually:

$ sudo ./tegrarcm_v2 --uid
File rcm_state open failed
ERROR: failed to read rcm_state

Device seems not poperly booted in this RCM mode.

I suspect it is not flashing the device because it fails to read it’s UID… Maybe if I can force flash it somehow it might get fixed?

It’s not the cause; it shows up even in a normal flashing log.

That’s all we can suggest.

Woow… While trial and error phase I just tried the sudo ./nvautoflash.sh from target/JetPack_6.0_DP_Linux_DP_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra and it just flashed!!! Can’t explain the joy…

[ 768.8956 ] tegradevflash_v2 --write B_MEM_BCT mem_coldboot_sigheader.bct.encrypt
[ 768.8963 ] Bootloader version 01.00.0000
[ 768.8990 ] Writing partition B_MEM_BCT with mem_coldboot_sigheader.bct.encrypt [ 243712 bytes ]
[ 768.8996 ] [................................................] 100%
[ 771.9416 ] Flashing completed

[ 771.9417 ] Coldbooting the device
[ 771.9432 ] tegrarcm_v2 --chip 0x23 0 --ismb2
[ 771.9445 ] MB2 version 01.00.0000
[ 771.9476 ] Coldbooting the device
[ 771.9490 ] tegrarcm_v2 --chip 0x23 0 --reboot coldboot
[ 771.9500 ] MB2 version 01.00.0000
*** The target generic has been flashed successfully. ***
Reset the board to boot from internal eMMC.

The only thing is I’m not sure is it something I changed in the BIOS/EFI or it just skipped this check I’ve mentioned earlier…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.