Orin has black screen after jetpack upgrade, fan 100% and "Reading board information failed"


  1. No screen output (including POST)
  2. Fan stuck on 100%, suggesting it never makes it past the boot-block
  3. Flashing returns “Error: Reading board information failed” and “target: Depends on failed component”

Steps that produced this one result:

  1. Have jetson AGX Orin developer kit with JetPack version 0.1
  2. Follow guide at: https://developer.nvidia.com/embedded/learn/get-started-jetson-agx-orin-devkit
  3. When installation gives a prompt not mentioned in the guide, abort
  4. Reboot

Additional information:

  1. Responds to num-lock key
  2. Followed steps on: Quick Start — Jetson Linux<br/>Developer Guide 34.1 documentation. Command “sudo ./flash.sh “jetson-agx-orin-devkit” mmcblk0p1” gives a long output followed by “Reading board information failed”. Can provide full output if needed
  3. Shows up in lsusb as: “Bus 002 Device 019: ID 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra”
  4. Entering force recovery mode changes ID to 0955:7023 NVIDIA Corp. APX
  5. Followed steps under “(1) How to use SDK Manager to Flash L4T BSP” on: Jetson AGX Orin Developer Kit User Guide - Two Ways | NVIDIA Developer which produced this log file:
    SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_AGX_Orin_modules_2023-09-21_10-46-41.zip (84.0 KB)
  6. Host PC is running Ubuntu 20.04 and is not a virtual machine
  7. Tested “sudo picocom -b 115200 /dev/ttyACM0” but can not log in to the device

Could you board work before?

What is Jetpack version 0.1?
Could you verify with the latest JP5.1.2(R35.4.1) for AGX Orin devkit?
Please refer to the following instruction to flash the devkit with SDKM.
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

Please also provide the full serial console log for further check.
(You may connect Micro-USB port to capture serial console log on /dev/ttyACM0)

Thank you for replying.

The board was indeed fully functional prior to upgrading, aside from the lack of cuda.

That is a good question. Might recall wrong, but calling " sudo apt-cache show nvidia-jetpack" returned this odd version number. Presumably, a dummy number meaning not installed.

That is the version that was used, unless there are other versions of 5.1.2. Note the file name mentioned in info [5]. Version R35.4.1 was also used in [2]. I did the GUI version of the flashing again, following the linked instructions for manual flashing which failed with these logs:
SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_AGX_Orin_modules_2023-09-22_11-58-02.zip (195.3 KB)
Took some images but could not figure out how to upload them here.

As for serial console logs. During flashing, the device is in recovery mode at which point “sudo minicom -D /dev/ttyACM0 -8 -b 115200” seems to connect but there is no log activity. I’ll attach the logs produced, by micro-usb serial, during normal boot instead:
minicom_230922.txt (55.1 KB)

Your sdkmanager log indicates the point mentioned in the orin FAQ.

If your host PC is not VM, then you can apply this method to your host.

→ Q: I get a USB timeout error during flash Orin. How to resolve that?

Please specify what point “the point” refers to

$ cat /etc/nv_tegra_release
cat: /etc/nv_tegra_release: No such file or directory
$ cat /media/jesper/L4T-README/version/nv_tegra_release
# R34 (release), REVISION: 1.1, GCID: 30414990, BOARD: t186ref, EABI: aarch64, DATE: Tue May 17 04:20:55 UTC 2022
$ cat /data/jesper/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/rootfs/etc/nv_tegra_release
# R35 (release), REVISION: 4.1, GCID: 33958178, BOARD: t186ref, EABI: aarch64, DATE: Tue Aug  1 19:57:35 UTC 2023

Googling these keywords suggested:

  • Using backup restore, but there is no backup to restore
  • Changing to 18.04. Unfortunately, I do not own the host server
  • Changing to 20.04.1. Same issue here. We are using 20.04.6. Sorry, should have mentioned this initially
  • $ sudo -s
    $ echo -1 > /sys/module/usbcore/parameters/autosuspend
    Tested, didn’t solve it
  • Pulling a script from git to fix version 5.0.2. Skipped, since it’s not for latest version

If I missed the answer in mind, please provide it.

Q: I get a USB timeout error during flash Orin. How to resolve that?

This command should be run on your board rather then the host PC.

Have you tried to switch another cable or port on your host PC?
Or the following operation could help for your case?

Plug out the USB cable, put jetson back into recovery mode again and plug the usb cable back.

Ironically the answer in the FAQs solved it. Simply missed re-plugging the cable.

$ sudo -s
$ echo -1 > /sys/module/usbcore/parameters/autosuspend

*re-plug cable*

$ sudo ./flash.sh "jetson-agx-orin-devkit" mmcblk0p1
*** The target t186ref has been flashed successfully. ***

Hats off to you two.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.