SDKMagager1.9.0 flash Jetson AGX Orin completed But the screen is black

I used SDK manager 1.9.0 flash Jetson AGX Orin 32G. At the end, it’s said - flash: Install completed successfully.

But,after I reset the board, the USB and Display has no sign. The screen is black.
I think that I flashed failed.

there are some error logs(I could’t update the log files.):
flash:[0.0051] ERROR: failed to read rcm_state
flash:[0.0679] Error: Skip generating mem_bct because sdram_config is not defined.

flash: gzip://home/host/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/kernel/Image: not in gzip format.

SUMMARY: Flash Jetson AGX Orin - flash: Install completed successfully.

What’s wrong?
Help me!

I copy the log here.After I flashed,I reset the board.But the DP does not work.
sdkm-2022-12-05-16-04-58.log (1.1 MB)


Welcome to the NVIDIA Developer forums! I am moving this topic to the correct category so the Jetson support team has visibility.


Hi 1016814269,

Are you using the devkit or custom board?
Do you run Ubuntu on the VM or standalone PC?
Do you connect DP-monitor directly from your DP port of board (w/o adapter)?

Thanks for your replay!

  1. I used the SDK manager to flash it. I am using custom board.
  2. I tried any environment. Tried VMware, Ubuntu 18.04, Ubuntu 20.04. Now, I am using standalone PC with Ubuntu 20.04.
  3. I connect DP-monitor directly form the DP port of board. And I tried connect it to other PC, the DP and monitor can work. The resolution ratio is 1920 * 1080.

Does my logs has any problem? I see some errors here.
such as:
flash:[0.0051] ERROR: failed to read rcm_state
flash:[0.0679] Error: Skip generating mem_bct because sdram_config is not defined.

flash: gzip://home/host/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/kernel/Image: not in gzip format.
But at last, it’s said:
SUMMARY: Flash Jetson AGX Orin - flash: Install completed successfully.

Now the DP, usb, serial, all of them do not work . I can’t see any message from the board. I don’t know does it worke or not…

These logs doesn’t matter due to normal log showing the same.

Could you help to capture serial log on /dev/ttyACM0 to check current status of the board?
NVIDIA Jetson Orin - Serial Console

No /dev/ttyACM0. I connect the serial to PC, I can’t see /dev/ttyACM0. So I don’t know which step I did is wrong.
After I flashed the board, I power it off,and wait about 15s power it on again. But there was nothing changed.

I asked the hardware enginer. We don’t use the USB Micro B(no Debug CPU, no Level Shifters). We connect UART3_DEBUG to RS232 translator, then connect to serial port(with RX /TX/GND ) of PC. Set band rate115200.

Please refer to the following instructions for the custom board according to your hardware design.
Jetson AGX Orin Platform Adaptation and Bring-Up — Jetson Linux
Developer Guide 34.1 documentation (

If you use SDKM to flash your board, it would use default configs for devkit.
You should see debug messages from UART3_DEBUG after flash if you configure well.

OK! Thanks!
We will try it again.

After I flashed the SOM,its power became 10W. Before that, it’s only 6W. Does it normal?

It looks fine.
You could use tegrastats to check power consumption, but you still need to enable serial console first to access this utility.

We tried to config Jetson_AGX_Orin_Series_Pinmux_Config_Template_1.5.xlsm. Let some pins are Output/Driver 1, after flash new gpio.dtsi file, They became High level. That means it works.
But there is no uart message of UART3 and DP sign as before. We would try it another ways.

Could you provide me another website with some cases about how to create the dtb file of Jetson_AGX_Orin_32G. I just found how to build kernel.
Just like this: NVIDIA Jetson Orin - Compiling Code .

It’s my first time to use NVIDIA. I’m sorry that ’I don’t known which dtb-files Jetson_AGX_Orin_32G use, and how to create and use them correctly.
Thanks again!

Take Jetson_AGX_Orin_32G as example.

  1. When you flash this board, you would select jetson-agx-orin-devkit-as-jao-32gb.
  2. It would call config from:
    jetson-agx-orin-devkit-as-jao-32gb.conf → p3737-0000+p3701-0000-as-p3701-0004.conf
  3. Check the content in p3737-0000+p3701-0000-as-p3701-0004.conf, you would know:
  4. Try to find tegra234-p3701-0000-as-p3701-0004-p3737-0000.dts in kernel sources
  5. Modify the device tree to meet your hardware design

You could refer to Kernel Customization for details.

Thanks for your reply!
Now I have some questions.

  1. When I use the SDK Manager tools to flash board,I check the log,it used ./ jetson-agx-orin-devkit mmcblk0p1. So I used this param (jetson-agx-orin-devkit ) to flash board. Just like I asked you before.

  2. When I used ./ jetson-agx-orin-devkit-as-jao-32gb mmcblk0p1,it always told me that message:
    Error: missing dtbfile (/home/host/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/kernel/dtb/tegra234-p3701-0004-as-p3701-0004-p3737-0000.dtb).
    So I thought I used a wrong param.

  3. After I saw your last replay,I tried it again. I copied tegra234-p3701-0000-as-p3701-0004-p3737-0000.dtb from builded source kernel to …/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/kernel/dtb/, then I execed it, there were some errors,
    Error: missing dtbfile (/home/host/nvidia/nvidia_sdk/JetPack_5.0.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/kernel/dtb/tegra234-p3701-0004-as-p3701-0004-p3737-0000.dtb).
    So I named tegra234-p3701-0000-as-p3701-0004-p3737-0000.dtb to tegra234-p3701-0004-as-p3701-0004-p3737-0000.dtb,But it doesn’t work. The log is the file that I uploaded.
    debug.log (119.1 KB)

  4. Where is the problem? I can’t find the right flash param and the right defalt dtb files. My SOM info looks like this: NVIDIA CORP Santa Clara Model:P3701 900-13701-0040-000

After I add something(bpmp_dtb = None) to ./ ;it can flash to next step. But there is another error:
can’t find BPFkernel_ tegra234-p3701-0004-as-p3701-0004-p3737-0000.dtb,
Why I use cmd ./ jetson-agx-orin-devkit-as-jao-32gb mmcblk0p1 need so many dtb files? But I use cmd ./ jetson-agx-orin-devkit mmcblk0p1, it can be flashed to the end?
Dose my env not right? Or my SDK Manager don’t support jetson-agx-orin-devkit-as-jao-32gb?

After I compared the two files named “flash.xml”. I found there are some dtb files be need.
where the dtb files come from?
flash.xml (36.2 KB)
flash1.xml (36.1 KB)


You could use the following command to flash your Orin 32G
$ sudo ./ jetson-agx-orin-devkit mmcblk0p1

The device tree files are always overlay, you might need to check .dts/.dtsi file to trace all device trees it used.

Because you are using custom board, so you could just flash your board with script.
In addition, you don’t need to modify the name of dtb, just modify the device tree where your design different from the devkit.

Thanks! I will try it again.
I used the cmd “$ sudo ./ jetson-agx-orin-devkit mmcblk0p1” ,it can flash the board, as I asked at first. But the board doesn’t work normally.
I think I should try the devkit firstly!

Yes, It would be better to use the devkit first to know all the flash procedures and related board configurations.

What is the UART bps? Now the custom board connect the debug-uart directly(RX/TX), so I connected it with 9600 or 115200, there were no data.

Baud rate for UART should be 115200.
Please refer to following instruction to setup UART console.
NVIDIA Jetson Orin - Serial Console