SDK Manager 1.9.3 not usable anymore

According to this thread, SDK Manager cannot be installed under Ubuntu 20.04, but Jetpack Setup Instructions mention it only can be used under Ubuntu 20.04.

So, it is broken now, or what is the case?

How should someone flash an OrinNX on proposed DevKit (Orin Nano)?

Please give an hint or link for clarify above questions.

Some terminology to reduce confusion: What gets flashed to a Jetson is “Linux for Tegra” (“L4T”). This is just Ubuntu plus NVIDIA drivers. JetPack is a GUI front end to the actual flash software, but does not itself flash (JetPack tells the flash software what to do). SDK Manager is the “smart” network layer on top of JetPack. One can actually flash on command line after manual install without ever using JetPack/SDKM.

The shorter answer is that if you flash on command line, then you can use a wider range of hosts. If you are flashing an Orin with JetPack/SDK Manager, then you need either an Ubuntu 18 or 20 host PC. Going to command line increases the range of host PCs, but lacks certain features and guarantees.

The flash software is called the “driver package” (used in combination with a properly set up “sample root filesystem”). The flash software runs on a much wider range of Linux host PCs than does JetPack/SDKM (the two are packaged together, but long ago there was no SDKM).

JetPack/SDKM is partially what limits the host PC Ubuntu release requirements. JetPack/SDKM can run on more releases of Ubuntu PC than what you can actually use. The flash target is what limits this as well. Let’s say that JetPack/SDKM can run on Ubuntu 18.04 through 22.04. However, a JetPack release is tied to an L4T release, and the particular Jetson model is limited to various L4T releases as well. For an Orin, L4T must be R34.x through R35.x. L4T R34.x is an experimental release; Orin NX did not always exist, and so Orin NX might be limited further in comparison to the original AGX Orin so far as L4T release goes. For example, if you go here to look at L4T releases which are compatible with given hardware:

…then you will find the Orin NX support did not exist until R35.2.1. All R34.x and R35.x releases require a host PC which is either Ubuntu 18 or Ubuntu 20. None of the Jetsons support a host which is Ubuntu 22 despite JetPack/SDKM being compatible with Ubuntu 22 (there are other NVIDIA platforms you probably don’t know about which do use an Ubuntu 22 host; Jetson is not the only platform JetPack/SDKM is used with). Older Jetsons (which exclude Orin, they are too new) could use only an Ubuntu 16 or 18 host PC despite JetPack/SDKM being able to run on Ubuntu 22. All of this is the intersection of what JetPack/SDKM can run on in combination with the flash target.

1 Like

I understand, but this does not clarify why SDK Manager cannot be installed under Ubuntu 20.04, see:


Additonally, flashing from CLI with L4T 35.4.1 using initrd flash method (not sdk-manager) does not work at all (see my other post).

Concluding: last option remaining is using sdk-manager on CLI (according to Linux Developer Guide | Flashing Support | Using Convenient Script)?

thank you for your long responses, not only to this thread, but also on other questions i had before in other threads!
This is what i expected from NVIDIA guys!

…Although this time, i knew all you described before and only wanted to mention that SDK Manager cannot be installed with current 20.04 Ubuntu which is needed for using it to flash by GUI (not script perhaps).

Sorry that I cannot read Germany. Could you clarify what is the exact thing shown on your screenshot?

Sdkmanager could be run over ubuntu20.04.

According to this thread , SDK Manager cannot be installed under Ubuntu 20.04,

And I didn’t give this conclusion to that thread either… please do out give a wrong conclusion… Sdkmanager can be used on ubuntu 20.04 and also can flash orin nano devkit.

The console output says that there are unmet dependencies.

Here is another picture with the log in us-english:

Note that all packages are up-to-date and there is no need to do an upgrade or anything like this.

Could you share the result of these 3 on your host?

sudo dpkg-query -l | grep sdkm
sudo dpkg-query -l | grep libgconf
sudo dpkg-query -l | grep libcanberra

It seems this is a dependency issue, but be assured that JetPack can install to an Ubuntu 20 PC. Something I’m thinking of trying:

sudo apt update
sudo apt --fix-broken install
sudo apt-get install libgconf-2-4 libcanberra-gtk-module

(if this succeeds it might reveal another package requirement)

I’m hoping that the “--fix-broken” will get at least part of the way there.

I meant to reply to @J4n_J4ns3N , looks like I replied to WayneWWW.

This does not fix anything because the packages are not available anymore in Ubuntu 20.04.06 LTS using the Desktop ISO for booting Live System from USB Drive:

This is shown on the picture above and again on the picture below (with inluded --fix-broken option, which certainly will do nothing because packages are not contained in the apt repo index!):

As you can see, there is no package libgconf-2-4 anymore.
Same for the libcanberra-gtk-module! Only available variant here is libcanberra-gtk3-module as you can see above!

Note that i had a running SDK-Manager Version some time ago on Ubuntu with Version <20.04.06 where these packages seem to exist (perhaps because some package repos are included which are currently not in the live system), so you are right that somehow it worked someday.

I have the same problem. sdkmanager1.9.3 cannot run on ubuntu 20.
I tried ubuntu 22, but sdkmanager tell me the host must be ubuntu 20 or 18.
Has this version sdkmanager been tested before release?

It seems that in current Ubuntu 20.04.06 LTS ISO Image the universe packages are missing from sources.list.

Adding them with sudo add-apt-repository universe makes them available and both packages mentioned above needed as dependency for sdkmanager can be installed.

Note that this problem only exists when booting the live system on the installation media.

After installing, the universe apt package repo is included and thus the sdkmanager can be installed as shown in the official setup guide.

I’m using sdkmanager on Ubuntu 20.04, but it isn’t a Live distribution version. I’m glad @J4n_J4ns3N found the sources.list issue, that would have been hard to find.

Just for those who are curious, sdkmanager did not always exist. There used to be just the command line L4T “driver package” plus “sample root filesystem”, and one had to download and set those up separately. Then JetPack came along, but it had no ability to work with downloads and certain features; along came SDK Manager, which was the network layer on top of JetPack. So sdkmanager is calling up installation scripts and then starts JetPack. I guess sdkmanager does not check the sources.list (it doesn’t even install some dependencies if missing), although it does install the base NVIDIA content.

Thanks to @J4n_J4ns3N for finding that missing universe repository on the Live distribution.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.