Sdkmanager not working

Subject: Trouble Installing Jetpack on NVIDIA Jetson orin Nano

Hello everyone,

I’m encountering some difficulties while attempting to install Jetpack on my NVIDIA Jetson orin Nano. Despite several attempts using different methods, I haven’t been successful yet. Here’s a breakdown of what I’ve tried and the issues I’ve encountered:

  1. Flashing directly onto SD card with Etcher: Unfortunately, this method didn’t work for me. I followed the usual steps with Etcher, but it didn’t result in a functional installation.

  2. Installing SDK Manager using a virtual machine: While I managed to install SDK Manager using a VM, I couldn’t detect the device. It seems this approach might not be feasible, as per discussions in various forums.

  3. Trying to install SDK Manager on a Raspberry Pi with Ubuntu 22.04: I attempted this using both the wget method and the sudo apt install method, but encountered issues with both.

    • With wget, it seemed to download something, but I couldn’t locate SDK Manager afterward, and it didn’t launch.
    • Using sudo apt install resulted in an error: “unable to correct problems you have held broken packages.”

I’ve scoured through numerous forums and threads, trying various suggested solutions, but nothing has worked so far. Unfortunately, I don’t have access to any other Ubuntu devices aside from the Raspberry Pi and a Windows laptop.

If anyone has encountered similar issues or has any insights into resolving them, I would greatly appreciate your assistance. Thank you in advance for any help you can provide.

Best regards,

Note that the Jetson still needs its boot content and “equivalent” of a BIOS to be a recent enough release. Flashing the QSPI of the Jetson is what solves that. Then the pre-canned SD card image should work.

VMs usually fail due to not having USB configured correctly for permanent pass-through (flash has the USB disconnect and reconnect, so even if the Jetson is found at start of flash, any VM not picking up USB reconnect will fail anyway). All VMs are different, so it is up to the end user to configure the VM if using one. If you must use a VM, then you’ll need to experiment with USB options (which I cannot help with).

The flash software runs only on a desktop Linux PC architecture. RPi is not desktop PC architecture and cannot be used.

Thank you for your response and insights.

Regarding the QSPI update, I understand that it’s typically handled through SDK Manager. As for the “pre-canned” SD card, I assume you’re referring to an SD card that comes pre-installed with the necessary boot content and BIOS equivalent. Is it possible for me to create one myself, or is it recommended to purchase a pre-installed SD card?

Regarding the issues with VMs, I am aware that this is difficult and not recomended. I’m currently experimenting with using a Raspberry Pi running Ubuntu 22.04 instead, but as u mentionned this is also not possible, does this mean i cant use my jetson? just becouse i dont have a linux desktop. is there anny other way to do this?
Is dual booting a windows laptop an option?

Thank you again for your assistance.

The SD card has only the o/s. The QSPI is on the module, and this is accessible only via flash while in recovery mode. This is why the SD card is not enough by itself…sometimes, if the module has been flashed before, you won’t need to flash again to update the SD card. However, if a major release has changed between SD cards, then the two SD cards (older major release versus newer major release) of one of those releases will fail to boot until QSPI is flashed to that release (and then the older SD card will fail to boot because it is not matched to that generation).

Any SD card which is large enough has images available for no cost. You just apply that content to the SD card, and it is ready…but only if QSPI on the module is correct. The Orin Nano can use L4T R35.x (Ubuntu 20.04 plus NVIDIA drivers) or L4T R36.x (Ubuntu 22.04 plus NVIDIA drivers). The SD card image to put on the SD is available with that release version. Pick the latest R35.x or R36.x (which is still developer preview) here:
(downloading the image is free)

SD card images tend to be installed via Etcher if you use Windows, or via dd on Linux. The documentation for that release is available to answer details at the same URL as above. Flashing the QSPI of the Jetson itself is only from a Linux PC. Using JetPack/SDK Manager is recommended (it is a GUI front end to the flash software and runs on the PC, not the Jetson), but this limits which Linux host PC can be used. If you have an Ubuntu 20.04 host PC, then it will work with either L4T R35.x or R36.x flashes.

If you use RPi for flash, then it will not succeed. This is due to CPU architecture…the flash software is desktop PC binary Linux. Putting an image onto SD works with any o/s. Dual boot is highly recommended on the host PC used for flash.

Thanks for the clarification.
I ended up searching for an old laptop and installed Ubuntu on it instead of Windows.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.