Brand new Jetson Orin Nano fails to boot

I bought a Jetson Orin Nano Developer Kit last week. I powered it on for the first time. The fan starts spinning when I powered it on, and the boot screen shows on the monitor. When I enter boot, the fan stops spinning, and the monitor goes dark. I tried powering off & on several times, every time the same thing happens.

Nanos use so little power that it is expected that the fan stops. It is quite common that video can fail, but the system really boots. However, you’d first have to flash the Orin Nano and make sure the flash content is for the SD card release you are using.

For reference, L4T (Linux for Tegra) is what gets flashed, and this is Ubuntu plus NVIDIA drivers. The GUI tool which does this (the front end) is JetPack/SDK Manager. The release of L4T is tied to the release of JetPack/SDKM, so if you’ve picked one, then you’ve picked the other. Orin works with either the R35.x L4T or the R36.x L4T. Each such major release (R35 versus R36) only supports SD card content from that release, and you can’t be certain which release ships with a Jetson. To find software for a given release go to either of these URLs (which also includes documentation specific to the release):

The small format dev kits (the size of a DIMM module on a carrier board) have an SD card slot on the module itself, and not on the carrier board (commercial models will have eMMC and no SD card slot on the module; perhaps an SD card slot on the carrier board). There is no eMMC, but there is QSPI memory on the module itself. Jetsons do not have a BIOS, but they do have all of the equivalent functions in software residing on the QSPI memory. There is a range of QSPI content which works with various SD card releases, but it is not 100% compatible across all releases of QSPI and all releases of SD card. In particular, L4T R35.x QSPI will never work with an L4T R36.x QSPI, and vice versa. A subset of QSPI content within a given major release (such as R35.x) is likely to not work correctly with an SD card content which is too far different in release. Thus, you need to flash the module itself.

An Ubuntu 20.04 host PC would work to flash either L4T R35.x or L4T R36.x (you can use Ubuntu 20.04 or 22.04 if you want R36.x). Command line has fewer restrictions. R36.x is still a developer preview (thus the “DP” you might see in its name). When in recovery mode the Jetson is a custom USB device, and the host PC runs the flash (which has the USB driver for that custom device).

Regarding monitors, you would need an actual DisplayPort or HDMI monitor. Adapters to older VGA won’t work. In all cases though serial console is the way to see what is going on during boot. Serial console boot logs are easy to obtain, and provide a lot of valuable information even if networking and video crashes and burns. See:

I don’t actually have an Orin Nano, but I think it still uses the micro-OTG port with a micro-B USB cable for serial console (which would be the same as an older Nano, which is not an Orin Nano).

Thanks for your reply. That’s a lot of info. It will take me some time to digest & see what applies to my situation.

Meanwhile, when I download JetPack 6.0 Developer Preview, I noticed this little note:

“If using JetPack 6.x SD Card image for the first time, you will need to update the QSPI bootloaders by installing JetPack 6 on your SD Card using SDK Manager, which will update the QSPI bootloaders as well. Please note that this is a one time requirement only. Once the QSPI bootloaders are updated, you can use JetPack 6.x SD card images for any future releases.”

I am indeed using the card image for the first time, and I don’t understand what “update the QSPI bootloaders by installing JetPack 6.x using SDK Manager”. It looks like SDK Manager is a package I install on a Ubuntu host machine. I don’t have a Ubuntu host machine. Can I use a MacBook Pro for this purpose? Does installing JetPack 6 on the card using SDK Manager automatically updated QSPI bootloaders, and the kit will boot on the so-installed JetPack 6?

JetPack 6 has some major changes in work flow which I am not yet familiar with (partly because I am running out of disk space and want to clone my old install prior to flashing!). I also don’t have an Orin Nano, I have only the AGX Orin, so I cannot experiment with the flash of QSPI.

The second paragraph from my previous response which lists the L4T and JetPack URLs, and their description, applies to this. What you will find is that the Jetson is a custom USB device when in recovery mode (Jetsons don’t have a BIOS, so they cannot self-flash), and that the custom driver (aptly named the “driver package”) is a Linux desktop PC architecture executable. This cannot run on Windows or a Mac. If you were to add a disk and dual boot, assuming it is the same architecture as a desktop PC (i.e., not the older Mac with the non-Intel CPU), then in theory you could install Ubuntu on the second disk (you would dual boot). I don’t know if there are other issues for a Mac running Linux, someone else would have to comment since I’ve never tried, but I think it would work.

Some people use a VM, but it is not officially supported. VMs tend to be a lot of trouble unless you get lucky, and each VM brand is different and will need a learning curve for any of them. The primary problem for using a VM is usually correct USB pass-through. You’d also have to be certain that the disk space you install to is ext4 filesystem partition type.

JetPack itself is just a GUI front end to the driver package. What you are installing to the host PC is the driver package, along with the JetPack/SDK Manager front end. The driver package itself performs the flash, and what it installs is “Linux for Tegra”, and this in turn is Ubuntu after installing Jetson drivers. The Ubuntu part is known as the “sample root filesystem”, and it used to be you would only download the driver package and sample root filesystem, run “sudo ./” to add the NVIDIA drivers, and then flash on command line. Considering that JetPack is rather useful, especially with JetPack 6 DP having new features, I think you will save frustration if you dual boot your Mac (I recommend add a second disk for Linux).

I do really hope someone else who has used a Mac running Linux might comment on whether this works. I’d hate to see you buy another disk and install dual boot and have it not work.

Dual boot my MacBook with a patriot for Ubuntu is what I ended up doing. Once I put a jumper on, I was able to flash the SSD card. And I ws tyrn able to complete the setup process. Thanks for your help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.