Not able to install SDK components through SDK Manager for Jetson AGX Orin developer kit

Hello Team,

Currently, I am trying to install SDK components through SDK Manager. Installation of Linux OS image was successfully done, however after flashing the system it again started the installation. At that time there are two options available for connections: 1)USB 2) Ethernet. I have selected USB as mentioned in the docs with default ip and provided the user credentials. When I clicked on the install button it gave following errors.

System configurations:
Ubuntu: 20.04 V (debian)
Jetpack: 5.0.2 (REV. 1)

I have also tried with Ethernet, at that time it was giving invalid username and password.

Pls suggest me how to resolve.
Best Regards,

Hi rajputnimesh.ds,

There are 2 parts of installation:

  1. Jetson Linux: flash main Linux OS to board → looks good in your case
  2. Jetson SDK Components: install related SDK packages → using apt to install, this step could be run after the board boot up

Do you connect a monitor for your board to check the current status (if boot up to desktop)? Or connect the console for UART log?

The error message showed that there are more than 1 Jetson connected on host PC. Could you help to try lsusb to check the device named NVIDIA Corp.?

Hi Kevin,

Yes, we do have connect a monitor and checking the status of board. However, we have also tried out with lsusb but it was not showing NVIDIA Corp. I have attached screenshot with this post for your reference.


Is there anything showing up on the monitor which connected from your board?

Could you help to capture UART console log for further check?
NVIDIA Jetson Orin - Serial Console

Hi Kevin,

I have found the solutions and its working fine. Thank you so much for the responses you have given.


Hi Nimesh,

My team is facing the same issue. Would you mind sharing the solution you found?

Thank you,

Hello phelanm2000,

We had flashed out the exisiting Linux OS and reinstalled it through SDK Manager, it was throwing errors while the components installation had been started. However, we had also tried with both the options: USB/Ethernet but no luck !. So we stopped and connect the Orin with monitor screen because OS installation was successfully done and through CLI we installed other packages.

sudo apt-get update
sudo reboot
sudo apt-get install nvidia-jetpack

It will install all necessary components. I hope it will help


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.