AGX Orin doesn't see CUDA

Hello everyone,
I configured my Jetson AGX Orin with standart way.

( sudo apt dist-upgrade
sudo apt install nvidia-jetpack )

As shown in the picture, CUDA is actually exist, but the device can’t see it. Can’t even see the jetpack version.
Also I’m trying to setup Jetson-Inference but cmake and make commands are not working.


1 Like

Hi furkankoc22,

Please use SDK Manager to install sdk components and check again.
SDK Manager download link: NVIDIA SDK Manager | NVIDIA Developer
Follow this page steps to install and run on your host ubuntu-18.04/20.04.

Thank you sir,

I tried it… but it looks NVIDIA SDK Manager is made for AMD64 processor but I have ARM64 in Jetson AGX Orin. So it gives error.
I decided to boot the AGX Orin with Ubuntu 20.04 image to do everything from start. So could you please help me about which version of sdk manager I have to download for ARM64 and when am I supposed to install SDK Manager… Before or after jetpack 5.0 ?

Hi furkankoc22,

The SDK Manager only can run on x86_64 host Ubuntu machine.
For AGX Orin, you can run SDK Manager on x86_64 host Ubuntu-18.04/20.04, follow GUI steps to flash JetPack-5.0 DP image and install sdk components.

Please reference below two pages for detail:

Hi sir,
I am not sure what is wrong but I am following guide from the link and I get error like,

WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested.

For other solution to reflash;
-my orin displayed these text on NVIDIA logo interface, follow the prompts press ESC without any response, and then the screen goes black.
-and there is no file like “flash.sh” in orin

I have the same issue and I tried to install the SDK manager but always having issues same as you.
So please if you find a solution please let me know and if I find one I will let you know as well.

Thanks,
Harry

1 Like

Certainly Harry,
I am going to…

1 Like

Seems to be an issue with the jetson_stats tools:

You could try nvcc --version to see if the cuda compiler is there.

Hi Harry, I solved the problem.
The matter was, I tried to install SDK Manager to AGX Orin Dev Kit so far. Probably you did the same as me. That’s wrong !!
There should be extra Ubuntu computer as Host PC and SDK Manager is supposed to be installed in it. I didin’t have Linux based computer so I did dual boost to windows based computer with Ubuntu image. In Instlalition guide, it shows how to do it. Firstly you will install SDK manager in Host PC and you will connect Host PC to AGX Orin Dev kit with C-type cable which is exist in package. Don’t forget to connect it to right C-type port and start Dev kit in Recovery mode.

(Btw I used " ubuntu-20.04.4-desktop-amd64.iso " image for host pc dual boot and worked)

1 Like

Thanks I will do probably the same as you 🙂