Jetson AGX ORIN - Blank Display

I managed to successfully flash a Brand new AGX ORIN using SDK manager from a Host PC using Ubuntu 20.04 but was still getting a blank display on my HDMI screen. I have tried display port to HDMI active adapter but till no go.

I followed the steps on

I tried re-flashing but ORIN does not show up on the host computer. It says no hardware connected on the SDK manager.

I also tried dmesg | grep --color ‘tty’ but no serial devices showing up.

Please help, i am a newbie

Hi user100392,

You can refer to the following link for the instruction of installing Jetson with SDK Manager
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

Are you using the development kit or custom board?
In addition, UART console log could be captured by Micro-USB port.

Thanks, I am using the development kit.

You also could try to connect to another DP display.
(w/o adapter transfer from DP to HDMI)

1 Like

Ok sure, will try and update. But why would the ORIN development kit not show up or get detected on the host computer.

If you are talking about type C cannot show you the Orin board, please refer to this post.

This solved the issue… Thanks