Orin Developer Kit shows blank after flash

Hi there,

Device: Jetson AGX Orin Developer Kit
SDK: Jetson_Linux_R35.4.1_aarch64
Symptom: I follow the instruction to flash the dev kit. After flash, I can see the dev kit reboot and enter kernel but after a series of kernel booting up log, the screen turns blank. Device is on, but the DP shows no signal on the screen.

May I know how to recover it?


How did you flash the device? With SDK Manager or flash.sh?
Are you sure it’s DevKit from NVIDIA, but not a third-party carrier board?
Are you still able to login via serial console?

Show me the following:

  1. lsmod | grep nvidia
  2. cat /var/log/Xorg.0.log
  3. xrandr

Hi there,

I used flash.sh to flash the device. It’s a DevKit from NVIDIA, which looks exactly like this.
It’s with NVIDIA’s carrier board.

I was not able to log into console because /dev/ttyACM0 was not created on my host Ubuntu PC. And I’m sure the USB micro-B port was connected to my host.

When I ran flash.sh I saw an error regarding “./rootfs/boot/extlinux/extlinux.conf” is missing. In order to get around with this error, I copied the extlinux.conf from ./bootloader/ to ./rootfs/boot/extlinux/

However, after research, I found a guide, and it says I need to run apply_binaries.sh first.

This time, I ran apply_binaries.sh before flash.sh and now the system is up and works fine. Even the /dev/ttyACM0 shows up on my host afterwards.

So, I think we can close this ticket.

Thank you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.