Jetson Orin Flash not working - Display black when connected with DP, Unable to install sdk components

I have a NVIDIA Jetson orin 64gb developer kit. For setting up Orin by a ubuntu 20.04 machine, I flashed the device using SDKManager 2.0, jetpack 5.1.2 Linux and the installation was successful. However, When I connect the device to display using a “display port to display port cable”, the screen is blank.

Nevertheless, I tried to proceed with jetson runtime components and jetson sdk components installation of the device using SDKManager, but I get the error “Not exactly one NVIDIA Jetson device is connected with USB. For using default IPv4 address, please connect exactly one Jetson device. This can be validated by running the ‘lsusb’ command on your host, and look for (NVIDIA Corp).”. lsusb does not list any NVIDIA devices (apart from the micro-usb connection of ORIN. Even that does not show if I remove the micro usb and connect only usb c). I am attaching the logs of minicom file while doing the Linux installation in both pre-config settng and run time setting.

Apart from doing this multiple times, Other things I tried:

  1. Install with display port cable disconnected and then connect it once flashing is done.
  2. Try different DP cable
  3. Use different jetpack version.

I previously setup Xavier with exact same steps (with a micro usb cable and with a different method to put it in recovery mode), it worked fine. The Linux installation through SDK Manager was successful and it booted into the log-in page (which I saw in a connected display). Then, I used the SDK Mananger to install jetson runtime components and jetson sdk components on Xavier. But I am facing issues with Orin.
minicom_orin_runtime.txt (114.7 KB)
minicom_orin_preconfig.txt (114.6 KB)


For the DP issue, we just double check with internal team and notice there is a UEFI patch that is needed to make it stable work.
1fdd2ed.diff (3.3 KB)

Please add it and build UEFI binary again.

Besides DP issue, actually I notice something weird from your log. It seems type C controller and ethernet port are not working.

If you are sure this is NV developer kit, could you also swap other modules to see if this behavior is all the same to those modules?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.