Newly flashed AGX Orin black screen on reboot

Process:

  1. Flash JP5.0.1 DP using SDKManager to EMMC.
  2. During the flashing process, it boots well and I can login.
  3. Finish successfully and I can use it without problem.
  4. Reboot. Nothing shows up. No NVIDIA logo. Nothing. I tried reflashing but same thing happens if I reboot.

I tried to get the logs from the AGX Orin but I am not sure how. Plugging the AGX Orin to desktop only gives me /dev/ACM*.

Relevant SDKM log:
sdkm-2022-06-17-14-23-41.log (1.7 MB)

So??? What does that mean the AGX Orin only gives your /dev/ttyACM*?

You should dump the log from that node then.

Sorry. Im not familiar with serial console. Here they are.
dmesg.0 (80.5 KB)
Xorg.0.log (18.6 KB)

No monitor is connected. What kind of of monitor is in use here?

[ 24.371] (–) NVIDIA(GPU-0): DFP-0: disconnected
[ 24.371] (–) NVIDIA(GPU-0): DFP-0: Internal DisplayPort
[ 24.371] (–) NVIDIA(GPU-0): DFP-0: 2380.0 MHz maximum pixel clock
[ 24.371] (–) NVIDIA(GPU-0):
[ 24.371] (–) NVIDIA(GPU-0): DFP-1: disconnected
[ 24.371] (–) NVIDIA(GPU-0): DFP-1: Internal TMDS
[ 24.372] (–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock

Dell UltraSharp 27. It detected before reboot though. This log is when it didn’t have monitor attached. I have only 1 monitor this log is generated when there was no monitor. Should I get log when its connected?

…yes of course…

minicom gives me this (full minicom log attached)
minicom.log (57.9 KB)

��ERROR: Exception reason=0 syndrome=0xbe000411
ERROR: **************************************
ERROR: RAS Uncorrectable Error in IOB, base=0xe010000:
ERROR: Status = 0xe4000612
ERROR: SERR = Error response from slave: 0x12
ERROR: IERR = CBB Interface Error: 0x6
ERROR: MISC0 = 0x44020040
ERROR: MISC1 = 0x4854860000000000
ERROR: MISC2 = 0x0
ERROR: MISC3 = 0x0
ERROR: ADDR = 0x8000000013800800
ERROR: **************************************
ERROR: sdei_dispatch_event returned -1
��

Which version of jetpack is in use here?

The version is JP5.0.1 DP

Do you hotplug the monitor or you connect the display from the beginning of boot?

Both doesn’t work.

I mean plugging the monitor before you power on the board. Any other cases consider to be hotplug case.

For that error, please refer to this post.

1 Like

Okay this one seems similar to my issue. I will try it. Thanks a lot!

Hi! I have tried replacing the uefi_jetson.bin and flashed without error but the issue persists. Now it doesn’t even output anything on the serial console. Do I have to replace any other files?

It is unlikely the case " it doesn’t even output anything on the serial console" may happen. Since UEFI is only part of the bootloader, there shall be other bootloader printing out logs to your serial console.

Only one case is maybe the serial console you are using is not the UART one at all. But the kernel one dumped to flash port.

Please be aware that the uart console is the micro usb port on Orin devkit. Not the type C.

Yeah I used the same microUSB port and minicom config. I was thinking maybe I need to replace the BOOTAA64.efi. And I don’t know what variables_Jetson_Release.bin is for. If that’s not the case, I will try flashing again.

Ok the orin is stuck in boot loop.

Synchronous Exception at 0x00000008543A4470
ASSERT [ArmCpuDxe] /home/wom/ws/edkrepo/nvidia-uefi/edk2/ArmPkg/Library/Default)

Resetting the system in 5 seconds.
����Shutdown state requested 1
Rebooting system …

Not sure why my edk workspace directory path comes up there.
minicom.dump (109.4 KB)

I checked out to the exact PR merge commit on edk2-nvidia and flashed after replacing uefi binary and BOOTAA64.efi. Now the nvidia logo shows up and I can go into boot options. But after that it black screens. I will try with debug binaries tomorrow.

minicom.dump (62.2 KB)