Redo initial setup for jetson orin

Hello everyone,

I don’t seem to find an answer for my question when searching on google.

I simply want to reset my Jetson AGX Orin Developer Kit to the way I received it out the box. Whenever I search for this I get redirected to installing a new SDK or something else.

To make things more precise, I want to start over by following this guide

starting from Step 1.

Please help me with this. Thank you in advance.

Jetsons don’t have a BIOS; the equivalent is in software. If this is an eMMC model, then that software is in partitions; if this is an SD card model, then the software is in the QSPI memory of the module. Embedded systems without a BIOS cannot self flash, and thus a separate host PC is required. You posted this in the Orin NX forum, but it belongs in the AGX Orin forum (maybe someone from NVIDIA can move this). Assuming this is an AGX Orin developer’s kit, this means it is an eMMC model.

L4T is what actually gets flashed, and this is just Ubuntu plus NVIDIA drivers. When a Jetson is in recovery mode it becomes a custom USB device understood by a custom driver that runs on the host PC and flashes over the correct USB port. If you have an Ubuntu 20.04 host PC, then you could perform a command line flash. Or, there is a GUI front end to the flash which does more; this GUI is JetPack. SDK Manager is just a smart network layer on top of JetPack that can automatically download and set up the host PC for flashing a Jetson. They have their versions tied together, so if you’ve picked an L4T (Ubuntu) release, then the JetPack version is also picked, or vice versa. You can find a correct release at either of these URLs, and they lead to the same web page:

You’ll want the most recent R35.x L4T release. Example: If you pick L4T R35.4.1, then you can also find it leads to JetPack 5.1.2. Just follow the instructions to download and install JetPack 5.1.2 onto your Ubuntu 20.04 host PC (technically, you could also use Ubuntu 18.04, but when JetPack 6 comes out, I’m guessing you’ll lose the ability to flash from Ubuntu 18.04).

If any of that is confusing, then just ask for more details here. I will warn you ahead of time that if you use a VM for the host PC that this is not supported (it can be made to work if you correctly set up USB, but that’s the realm of the VM support).

1 Like

First of all, thank you so much. This is an overwhelmingly quick and helpful response. I will come back to this post once I get my hand on a linux pc next week. Currently, there is only WSL2 on my laptop and as per your last remark I will not attempt anything with it.

Hey, me again. I am once again lost as for what to do next.

I decided on the GUI approach using a Laptop running Ubuntu 20.04 as a host PC and the included USB A (Laptop) to USB C Cable (Jetson AGX Orin, Type-C next to 40pin header) to directly connect it to the AGX Orin which is also in Recovery Mode and also recognized as such by the SDK manager.

This is a clean minimal install of Ubuntu with the only additional install being the SDK manager. After having logged in and selecting the correct Orin

The SDK Version selected itself to 5.1.2 and I did not change it.

I proceeded to step 2 as such

And then on to step 3 (after entering sudo password) and creating the Jetson Linux Image as follows

the flash fails every time after 1% or 2% progression (EDIT: using the other option in OEM Configuration yields a failed flash as well)

with this log (136.8 KB)

I have tried using different USB ports, restarting the PC and the Orin and also found someone saying this command would help: sudo bash -c ‘echo -1 > /sys/module/usbcore/parameters/autosuspend’,
but to no success.

What did I miss, what are my next steps. If it is something obvious, please let me know.

Thanks in advance once more! :)

I think what you are doing so far is correct. I’m not as good with GUI flash logs, as I don’t know the meaning of lines such as this:

20:20:10.202 - error: Failed to validate GA4 event. Validation errors: [{"fieldPath":"events.params","description":"Event param [number_value: \t 422726] has invalid name [retryindex: 0, component: nv_l4t_flash_jetson_linux_comp@jetson_agx_orin_targets#35.4, error code: 1011. error: failed to execute commands with genericinstaller. failed in flash: . ]. Only alphanumeric characters and underscores are allowed.","validationCode":"NAME_INVALID"}]
20:20:10.208 - info: Timing validation passed with success
20:20:10.210 - error: Failed to validate GA4 event. Validation errors: [{"fieldPath":"events.params","description":"Event param [number_value: \t 6139] has invalid name [retryindex: 0, component: nv_l4t_flash_jetson_linux_comp@jetson_agx_orin_targets#35.4, error code: 1011. error: failed to execute commands with genericinstaller. failed in flash: . ]. Only alphanumeric characters and underscores are allowed.","validationCode":"NAME_INVALID"}]

I do see this which tends to be from USB issues (often from a VM, but you are not using a VM):
[ 0.5420 ] ERROR: might be timeout in USB write.
(I think this latter error is sometimes from hardware failure)

I did see that the host side QEMU was successful, so I don’t think it is related to broken host package management.

Maybe @WayneWWW could look at the logs. I am betting on either a simple USB issue, or hardware failure.

One thing you might do is log a manual flash on command line which removes some of the variables. You will have this directory on the host PC:

From that location you might attempt a command line flash while logging, and then upload the log:
sudo ./ jetson-agx-orin-devkit mmcblk0p1 2>&1 | tee log_orin_flash.txt

To aid with knowing what the Jetson itself is doing you might want to start a serial console to the Jetson itself and keep logging throughout the flash. You would then have a flash log from the host coupled with the log of what the recovery mode Jetson says during the flash. Just make sure connect serial console to the Jetson, clear the log, and then start the Jetson in recovery mode (this way you get everything the Jetson says from that point forward).

1 Like

Hello, sorry for the late reply. I wish I had better news but my current state is this. I did the exact same procedure a third time (sanity check) with the only difference being the way I put the jetson orin agx into recovery mode. Before I put it into recovery mode while the Dev Kit was powered on as instructed here

This time around I had it turned off and put it into recovery mode as specified for powered-down dev kits according to the same guide. I also freshly installed ubuntu 20.04 and the sdk manager as in my previous attempts.

I have no idea why, but the flashing using Nvidia SDK manager GUI just worked. I did however encounter to pop-up messages stating something along the lines of (they disappeared to quickly for me to screenshot) “device disconnected” & “device connected”. After that the flashing progress bar started filling.

Even with this pseudo-solution to the problem, I am very grateful for your help in finding the culprit for the behaviour.

Thank you very much!

Glad it worked out! FYI, it isn’t unusual for minor changes in the host, or cables, or flash software to make it “just work”. There are still mysteries in the universe…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.