Jetson AGX Orin DevKit won't go into recovery mode

My Jetson AGX Orin seems to work properly, it was flashed using a host computer and Nvidia SDK manager.

I need to flash it again.

I can’t get it into recovery mode, whether i follow those steps Jetson AGX Orin Developer Kit User Guide - How-to | NVIDIA Developer , (both when it’s powered on and when it’s powered off), the steps detailed by the NVIDIA SDK Manager itself or when using the “sudo reboot --force force-recovery” command line.

When trying those things, the device either stops and stays off (command line), or starts again, going onto Ubuntu’s desktop (buttons).

(One point maybe worth mentioning is that when entering the BIOS, it states “0 GB of RAM”, and the device had issues with cuDNN which, according to the forums, could have been related to VRAM usage.)

Any suggestions ?



What does that mean device stops and stays off? The power LED is not ON?

Hi, the power LED is ON, but the fan is not running, and display stays black. Nvidia SDK Manager doesnt detect the Orin aswell

Which port are you using to flash?

The USB-C next to the 40 pin header to flash and the other one to power. It seems that it is not entering recovery mode regardless of being connected to a host or not.

Could you use the serial console port (micro usb port) on your board to confirm whether this board is in RCM?

I tried, but when i follow this tutorial (NVIDIA Jetson Orin - Serial Console - RidgeRun Developer Connection), i’ve got either :

-Nothing is detected when i connect it to my laptop’s first USB port (/dev/ contains tty but no ttyACM)

-My keyboard stops functionning if i connect it to my laptop’s second USB port, and i can’t run commands using only my mouse (USB Port is otherwise working fine when tested with a wired mouse)

Is your laptop a native ubuntu host?

No, i’m running Ubuntu 22.04 on Docker on a Win11 laptop. Want me to try on a native ubuntu laptop ?

Yeah… basically we don’t guarantee your host setup would work

First, sdkmanager does not support ubuntu 22.04. Second, it sounds like your board is in recovery mode but the usb detection has some problems.

1 Like

Okay, thank you very much, i’ll try.

Recovery mode is supposed to have the fan turned off ? And it’s possible to know if it’s in recovery mode only by checking the logs ?


Yes the fan is off in recovery mode.

And the reason to check serial logs is because when the board is in recovery mode, you shouldn’t see any log from it.

Some users would think their board is in RCM but it turns out not.

The first comment you said about "When trying those things, the device either stops and stays off ". I only think this is normal behavior from recovery mode.

1 Like

Oh alright, thanks a lot, i’ll try and will get back to you if there’s actually an issue with the Jetson or if the issue was with the host.

Have a good evening

Okay, using a native Ubuntu 20.04 (without Docker), and flashing worked perfectly and on the first try. I still have to test if everything works but this issue is solved.

(Before that i also tried Docker Ubuntu 20.04 on my Win11 but it wasn’t working so i guess docker on Windows is NOT possible for SDK Manager, you need a native Ubuntu, or maybe with WSL like here Windows Subsystem for Linux :: NVIDIA SDK Manager Documentation, but i haven’t tried.)

Thank you very much for your help.

(Also : Could you please write somewhere in one of the guides on nvidia website that in recovery mode the fans are turned off and nothing is shown on the screen ? I spent a lot of time trying different things expecting a different behavior. Thanks again.)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.