Nvidia orin doesnt work

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other: 945-13730-0000-000

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other: computer with 20.04 Linux

Orin no display. Like everybody , my experience is the same. The box is dead on arrival

I tried to reflash it. Bought a new computer with Ubuntu 20.04

The reflash doesnt work. The details are in

filed under different email address. Asked to refile with coporate email.

Your topic was posted in the wrong category. I am moving this to the Jetson AGX Orin category for visibility.

Hi amaunder,

I’ve seen your situation from another post (Orin not starting).

Do you use the DP-monitor directly connecting to your Orin devkit?

You could refer to the following link for detailed steps to install jetson with SDK Manager. (This might be helpful for your questions about setup)
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation

I recommend that you install it with Manual Setup.
You should enter Force Recovery Mode before you do manual setup.
To Determine Whether the Developer Kit Is in Force Recovery Mode

And please help to dump full log from SDKM.
There is a button on SDKM to export full log (Upper right corner “…” → Export Debug logs).

linux1@linux1-XPS-13-9310:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 052: ID 0955:7023 NVIDIA Corp. APX

Monitor is directly connected through HDMI to Displayport adapter but not needed for now. No flash situation

It starts to flash and then fails with following message: could not detect target hardware (even though it detected it in the prev step and actually started to install). See the attached screenshot

SDKM_logs_2022-11-27_21-30-02.zip (769.3 KB)

Attached is the full log as recommended

Is this a ubuntu 20.04 host?

linux1@linux1-XPS-13-9310:~$ cat /etc/os-release
VERSION=“20.04.5 LTS (Focal Fossa)”
PRETTY_NAME=“Ubuntu 20.04.5 LTS”



Could you help provide the log during flash from your device with below method?

Currently, you only provide the host side log and we want to check the device side log.

Connect the micro usb cable to your jetson Orin devkit, open the console and start the flash process again.

Please be note that I am talking about the micro usb port but not type C.

Did you send a micro USB cable or do I have to buy one?

I assuem the other end is USB 3.0 to connect to the host computer

What console? My host computer terminal? SDK Manager?

ORin is dead. Nothing shows on display.

Please describe what console? What do I do there? How will I fetch the device logs

I know its all very obvious to you guys

Found a cable. Connected to microusb on Orin

Now what? I tried flashing it again with sdkpuppet

where do I get device logs
Where is the console?


Did you see the website link I posted in previous comment? There is guidance.

I think I saw it. Maybe I missed a link. Below are the screenshots. Please tell me what to click?

I am really lost.

Its a brand new Orin.

I connected to the Display. Its dead
I try to flash it . Its dead
I dont understand the instructions either.

Cant find the link, the console, the wire

I have purchased a computer, an adpter (hdmi to display port). Hunted for some microusb cable too.

Now the system doesnt allow me to put two screenshots

Please calm.

I mean the link in below comment… NVIDIA Jetson Orin- Serial Console

inicom -D /dev/ttyACM0 -8 -b 115200
minicom: cannot open /dev/ttyACM0: No such file or directory

ls -al /dev/ttyACM*
ls: cannot access ‘/dev/ttyACM*’: No such file or directory

tried with sudo also

orin microusb to usb 2.0 to usb 3.0 to computer

Could you take a photo of your cable connection?

One end is connected to microusb. Another end is open. This goes to my linux machine

I am in Bay Area. Is there an Nvidia Lab where I can bring this box?


When you connect the micro usb cable, do you power on your jetson?

I am in Bay Area. Is there an Nvidia Lab where I can bring this box?

Sorry that there is no such service here.

Still dead. I bought another one. That is dead too.

Can anybody who bought Orin that is not dead contact me? bdgp01@yahoo.com and maybe I can learn something.

I assume, that brand new Orin when connected to monitor will show something. Anything. Two in a row dead. Is there a special requirement for monitor?

I bought the displayport to HDMI cable too. Doesnt work