SDK Manager: Jetson Detected, but Could not detect a board, so can't flash

I’m trying to flash a Jetson AGX Orin Developer Kit using SDK Manager 2.1.0.11682 x86_64.

The device is in force recovery mode, following these instructions to determine whether the developer kit is in force recovery mode to check using lsusb.

lsusb
Bus 001 Device 017: ID 0955:7023 NVIDIA Corp. APX

When SDK Manager starts up, it shows Jetson Detected. Good so far …

After SDK Manager downloads and builds the OS image, it says, Could not detect a board:

The Flash button is disabled because it can’t detect a board. I’ve tried clicking refresh, and also following steps 2 to 6. Still the Flash button is disabled. because it can’t detect a board.

At the same time, lsusb still shows the 0955:7023 NVIDIA device is connected.

Please help.

Then does flashing manually with scripts work?
https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/IN/QuickStart.html

I have tried manually flashing with scripts.

Looking into flash.sh, it appears to fail when trying to run bootloader/tegrarcm_v2.

I normally run everything inside docker containers, and running this command returns nothing:

nvidia@container:~/nvidia/nvidia_sdk/JetPack_6.0_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra$ sudo bootloader/tegrarcm_v2 --new_session --chip 0x23 --uid

However, it works without docker, on the host:

nvidia@host:~/nvidia/nvidia_sdk/JetPack_6.0_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra$ sudo bootloader/tegrarcm_v2 --new_session --chip 0x23 --uid
BR_CID: 0x80012344705E35E03C00000018020280

Is flashing jetson from docker containers supported?

You need to take care of USB devices mapping:
https://docs.nvidia.com/sdk-manager/docker-containers/index.html#additional-considerations