Upgrading AGX Orin devkit from 5.0.2 to 6.0 DP by reflashing SSD - SDK manager doesn't see the board

I have Version: 5.0.2-b231 of jetpack, flashed long ago on SSD NVMe by SDK manager. Now I would like to upgrade to JP6.0, and there are many threads where the Manager doesn’t see the board, I have the same problem.

Although the board is probably in forced recovery mode because when I check with
sudo dmesg --follow
I get:

[  222.730162] usb 1-1: new high-speed USB device number 7 using xhci_hcd
[  222.880000] usb 1-1: New USB device found, idVendor=0955, idProduct=7023, bcdDevice= 4.01
[  222.880014] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  222.880021] usb 1-1: Product: APX
[  222.880026] usb 1-1: Manufacturer: NVIDIA Corp.

Which means that devkit is in recovery mode according to Quick Start — Jetson Linux Developer Guide documentation

Can I flash the board using: Flashing Support — Jetson Linux Developer Guide documentation
$ sudo ./flash.sh <board> nvme0n1p<x>


$ sudo ./flash.sh jetson-agx-orin-devkit /dev/nvme0n1

Like in After AGX Orin enters the recovery mode, the USB APX driver is incorrectly identified - #9 by linuxdev
Or is it more involved?


  • Why doesn’t the Manager see the devkit?
  • Is it beacuse it’s too old Jetpack?
  • Because it’s flashed on NVMe?
  • Can I download the correct AGX Orin Jetpack using sdkmanager? (I only see ~/nvidia/nvidia_sdk/JetPack_6.0_DP_Linux_DP_JETSON_ORIN_NANO_TARGETS that I used on nano ) and flash it using ./flash.sh?
  • is $ sudo ./flash.sh jetson-agx-orin-devkit /dev/nvme0n1 enough?

( EDIT: I have latest SDK Manager with 22.04 host, and I already upgraded Orin Nano to JP 6.0 from JP5.x once )


  1. Jetson has to be in recovery mode so that sdkmanager can see it.

  2. Too old sdkmanager can have some problems too. But (1) is always true and must be done first.

is $ sudo ./flash.sh jetson-agx-orin-devkit /dev/nvme0n1 enough?

Nope, flash.sh won’t flash anything to external drive. It can only flash emmc. Just let sdkmanager do this work for you first.

Weird, I uninstalled the old Jetpack 6 data, and downloaded it again, restarted Manager and put devkit to recovery mode again, and now it detected it. I remember the previous JP5 installation was corrupted somehow, and some libraries failed to install, but I didn’t mind at that time since I just wanted to get it working.

I guess it was good to write this post after all, since I didn’t do anything hasty with CLI and just tried old “have you tried turning it on/off again” 😅

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.