Unable to Enter Recovery Mode

Hello there,
I am having trouble forcing recovery mode on my Jetson Orin AGX Devkit. My issues are almost exactly the same as this post: Jetson AGX Orin can't turn into force recovery mode.

I followed all the steps outlined in the above thread with no progress. The solution identified at the time was to RMA the device. Customer support requested I post a new thread asking for assistance as the prior one was from 2022.
If there is anything else I can try to flash my Orin suggestions would be very appreciated.

Are you using a native Linux host PC? Or is it a VM? If VM, then this is usually a problem. If not, then you should use the JetPack log export button and attach the flash attempt logs.

I am currently using WSL as this is how I flashed it originally (Windows Subsystem for Linux (WSL) — sdk-manager 2.0.0 documentation), I will switch to a native Ubuntu system and report once I get a chance.

I was under the impression there was something else wrong as “usbipd.exe list” does not show the Nvidia device to pass through to Ubuntu even when using the Force Recovery Mode function.

I’ll post those logs as soon as I get them. Thank you for your help.

I have attempted this using a native Ubuntu 20.04 machine. I was not able to find the Nvidia Device in lsusb and SDKmanager could not detect the device despite using the Force Recovery Mode methods.
How do I go about getting the Jetpack log in this case?

When you try to flash with there is a button for export logs. This produces a .zip file of the logs which you can attach to the forums.

If you flash on command line, then you can append " 2>&1 | tee log_flash.txt" and this will produce a log of command line flash. Example for an AGX Orin dev kit:

sudo ./flash.sh jetson-agx-orin-devkit mmcblk0p1 2>&1 | tee log_flash.txt

(for an initrd flash a similar command should work, but I’ve never tried with that)

I have to emphasize that the flash log is not always as important as an actual serial console boot log.

Following this guide: NVIDIA Jetson Orin - Serial Console

I tried to get serial output from the micro-usb B but ls /dev/ does not show any tty connection.

Is there something I am missing here?

I tried to flash using the native linux sdkmanager but could not get it see the Orin and the flash was skipped.

Please find the logs attached.
SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_AGX_Orin_modules_2024-01-17_20-20-48.zip (122.6 KB)
Thank you for your help.

According to the log it was able to complete flash. Keep in mind that after flash completes the unit will self-reboot, but it had to be in recovery mode to get that far. It is indeed in recovery mode, that’s guaranteed by the completed flash.

It isn’t until the reboot occurs and first boot account setup is complete that networking comes up for installation of optional components, e.g., for CUDA. Those components may “seem” to be from flash, but they are not…those are installed over ssh on the network of a fully booted (rebooted) Jetson with the admin account that had its creation on first boot. If there is a failure at that stage, then it is due to not being able to access ssh.

The lack of ssh can be because of either a lack of networking (when address is used, this implies the virtual wired network router over USB is used from a fully/normally booted Jetson) or lack of login account. If this is a case of account missing, then first boot setup failed. If this is a case of the network device not being found, then most likely it is due to the host PC’s security not allowing that virtual USB wired router device to be used until ok’d.

You cannot use video to determine if boot failed, nor to determine if flash failed. Only serial console works for this. However, the device you see looks the same for recovery mode versus when fully booted. Even so, they are two distinct devices. The flash completed, and so recovery mode did in fact succeed. After reboot (which is automatic at the end of flash) the device you’d see is for virtual wired ethernet, and that device cannot work if boot fails. The wired ethernet is a result of a service that runs upon full boot. Serial console though is from a different connector, and that device will exist and be useful 100% of the time. I just want to be very careful to look at the right device from the correct USB port, and to not mistake either recovery mode or virtual ethernet devices for serial console.

I want to verify that this is an AGX Orin developer’s kit, and not a third party carrier board with Jetson module. If this is a third party carrier board, then it needs different firmware, and the wrong firmware can mean ports don’t function correctly. So far it sounds like this is an AGX Orin dev kit.

Looking at the 40-pin header, the USB connector on the right is for flash, and the USB connector on the left is for serial console. With the unit powered on, but the left side serial console cable not connected, monitor “dmesg --follow” on your host PC. This gives a continuous readout of logs. Now plug in that USB connector on the left side to the host PC. Does any log message occur as a result of the plugin? If so, then this is the UART used with serial console. What is the log which appears as the result of the plugin? If none, then you would indeed have a failure (assuming the cable is good; try different cables and ports if not).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.