Could not put the Jetson AGX Orin into force recovery mode

I was trying to put the Jetson AGX Orin board into recovery mode for the image flashing.
But I tried many methods from official guide and methods from the below page: Jetson AGX Orin can't turn into force recovery mode, I also try the command “sudo reboot forced-recovery”, the board still can not enter into the recovery mode, but boot up to the Ubuntu Desktop.

Attachment is the serial log, please help to check the issues, and how can I put the board into force recovery mode?
orin_bootup.log (83.0 KB)


I am not sure why you share me a boot up log while you are asking recovery mode issue.

How about you share me a log to see what happened after you run that forced-recovery command?

Sorry for the confusing file name, actually it’s the log file after the forced-recovery command running to the system boot up.
I get a another full log after the command running, please check that, Thanks.
orin_reboot_forced_recovery.log (83.7 KB)


Please try these two ways here

  1. Directly using sdkmanager to flash your board. Let sdkmanager to try to put your board into recovery. You don’t need to use any command or button.
    → I expect this might also fail.

  2. Please use the button to put the board into rcm. Also, share me what method you are using on these buttons to put it into rcm. Also monitoring the uart log when you do it. UART log shall not trigger another reboot.

I follow the steps below to put it into rcm, please check:

  1. Plug the power cable
  2. Hold the recovery button
  3. Press and release the power button (still hold the recovery button)
  4. Release the recovery button

Also upload the video and UART log below.

orin_recovery2.log (90.6 KB)


I notice the LED lights up when the moment you press the button in the middle, are you sure that is recovery button?

I think yes, I follow this guide, the middle button with No.2 mark is recovery button.
I tried hold the middle button firstly, then plug the power cable, the LED light will still on in one second, then it boot up to Desktop finally…

orin_recovery3.log (83.3 KB)

Hi @huzhengxi

Sorry, just some questions here.

  1. If you just power off the board, plug in the power cable → will the board boot up?

  2. if (1) is “no”, If you power off the board, plug in the power cable, press and hold the middle button “only” for 5 sec → will the board boot up?

You can use the serial console log to tell, it will be more precise.

Q1: Yes, the board will boot up after the cable plug in automatically (I do not press the power button). (see case1.log)
Q2: I follow the method. At the beginning, there is no output in the console, but after about 30 seconds, the serial console start to output something, and the system boot up. (see case2.log)
case1.log (60.6 KB)
case2.log (82.5 KB)


If the answer of question 1 is yes, then you cannot press power button to enter recovery mode. You need to use rcm button + reset button to enter recovery mode.

I tried this method, still failed, please check:

  1. Hold the recovery button (now the system is on)
  2. Press the reset button and release
  3. Still hold the recovery button for 5 seconds, then release it.
    The console will no output at the beginning, after about 30 seconds, the serial console start to output, and then boot to Desktop finally.
    reset_then_recovery.log (82.6 KB)


This sounds like a hardware problem.

Just one stupid test, could you check if you can flash the board in that 30 sec gap? Only run shall be sufficient.

Or check if the board really goes into a status that has no response in that 30 sec.

1 Like

It seems no response from the system in the 30 sec gap. I tried to run " sdkmanager --listconnected" and “lsusb” command in the Host, but no output message to show the device is connected. If it is a hardware issue, what should I do next step?
BTW, where can I download the script? Thanks.

sdkmanager will download it to you if you ever run it once. Default path on ~/nvidia/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.