AGX Orin not entering force recovery mode

I followed the instructions for entering force recovery mode using the buttons on the device but got no results. I also tried entering this mode through the terminal, but it just turned off my device.

Basically, I’m getting the same issue detailed here:

What advice do you have for next steps?

Do you have other Jetson AGX Orin on your side that can validate your method to put a board into recovery mode is correct?

Cannot enter recovery mode is hardware problem but most of users here are not that kind of issue. They just use the wrong method .

I do not have another AGX Orin to validate this on, but I am quite sure I have followed the correct steps for entering force recovery mode based on the documentation.

I have tried holding down the force recovery button and either pressing the Reset button (if already powered) or the Power button, then releasing both buttons. I have also tried using this command in the terminal:

sudo reboot --force forced-recovery

Does that mean this is a hardware issue, or are there other methods to explore?

Just to clarify. How did you know your board is not in recovery mode?

When I follow the instructions given here:
the device is not visible.

Trying to enter force recovery mode often results in the device powering off.


What is the power supply in use here?

Also, which usb port are you using on your side?

The power supply being used is the one that came with the device, here is a photo of the unit:

I connected the USB C port labeled #10 on this diagram to the USB A port on my laptop:
Screenshot 2024-05-12 092959

The Orin was visible in my computer’s device manager but was not visible via the lsusb command.

Sorry, what is the host PC you are using there?

I use a Razer Blade 15, which typically has a Windows environment, but I have been running through WSL with Ubuntu. I also installed the SDK Manager through WSL, and the board was not visible there either.

Sorry, could you try a native ubuntu host to test? I wonder WSL really can correctly detect recovery mode or not.

I just tried it on a native Linux machine, and it worked. I appreciate your help!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.