Jetson Orin Nano fails installation via SDK Manager: DateTime Target Setup - target: Depends on failed component

I’m having trouble setting up the Jetson Orin Nano Developer Kit 8GB with the JetPack 6.0 Developer Preview, using the SDK Manager, trying to flash the SD Card.
The error message is: DateTime Target Setup - target: Depends on failed component.


The operating system appears to be installed, but the installation is failing:

The logs contain a few repeating errors (I tried the process a few times), but none of these errors mean much to me, in order to resolve.
I’ve attached the log zip file.

Are you able to please guide me as to resolving the installation issue?

As a side note: The reason I’m using the SDK Manager is since flashing the SD Card directly, resulted in an issue where the Nano keeps shuting down after displaying the message “The L4TLauncher: Attempting Direct Boot”. I didn’t take that route much further, and the following thread suggests “sdkmanager is already the most correct official way”

SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_Nano_modules_2024-04-06_19-30-51.zip (204.8 KB)

I have the exact same issue. I have an NVME SSD on the orin nano. I tried with both SDK manager 2.0 and 2.1 but both returned the same error.
This had not happened before. Had successfully flashed the orin nano with SDK manager 2.0 in the past

sdkm-2024-04-07-19-06-24.log (317.8 KB)
Here is the log file

Are you sure the device is connected correctly when the error happens?
Does swapping for another USB cable make any difference?

Hi Dave,

It definitely appears to be connected properly.

When I run:
usbipd attach --wsl --busid x-x

The device becomes visible in WSL:
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0955:7523 NVIDIA Corp. APX
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Also, as soon as I run the attach command, the SDK Manager also automatically pops up the prompt, asking me to select:
image

This process occurred during the capture of the provided logs, prior to the failure.

I’ve tried with various USB cables.

You didn’t tell me you were using WSL2 at first.
Please find a real Ubuntu PC and test again to make sure it’s not a connection issue of WSL2.

I love how all the solutions to this I keep seeing are you need a ubuntu pc. After paying $500 for the board we should go out and buy another pc for the soul purpose of flashing this board. Couldn’t get a warning up front at least. “Oh by the way if you plan on using anything other than an sd card to run this you need a computer running ubuntu”. Literally an nvidia gpu on my windows desktop.

I’ve managed to flash the Orin Nano successfully using an Ubuntu computer running SDK Manager. There are some problems with drivers, wifi, bluetooth and some other expected functionality is missing/failing. I’m guessing that this is a problem with the Developer Preview image, rather than the install failing per-se. I will seek to resolve these issues individually. This thread can be closed, and I will use an Ubuntu computer, running SDK Manager, to flash the device in future.

During the install, it appears to disconnect and reconnect multiple times. Using WSL, when disconnecting a USB and reconnecting, the user must re-attach the device to WSL manually, otherwise it doesn’t reconnect. This is perhaps the problem with using WSL.

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.