Jetson Orin Nx update the Device Tree

I successfully upgraded the system through the command “sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 p3509-a02+p3767-0000 internal”
Now, I just want to update the device tree, What command am I supposed to use?

I would suggest flash the whole board to apply any change.

Or you could try the following command to flash kernel dtb only.

$ sudo ./ -c bootloader/t186ref/cfg/flash_t234_qspi.xml -k A_kernel-dtb p3509-a02+p3767-0000 mmcblk0p1

my board have no eMcc, so I can not use mmcblk0p1

Your module has QSPI and the boot content should be inside it so that you could try using that command to update A_kernel-dtb partition.
Or you could just replace the /boot/dtb/kernel_XXX.dtb on your board.

My board can only recognize USB3.0 devices and cannot recognize USB2.0 devices, which makes my keyboard and mouse unusable. When I plugged in the mouse, my board’s serial port output the following error. I tried to modify the device tree, but it didn’t work. Can you give me some suggestions for modifying the device tree

I attempted the following modifications to the device tree

The following is my hardware design

Mouse should work with USB as default.

Please file another topic for USB issue and share the following information.

  1. Devkit or custom board
  2. Jetpack version
  3. full serial console log
  4. block diagram of your connection
  5. Any HW design difference from the devkit
  1. custom board
  2. JetPack_5.1.1_Linux_JETSON_ORIN_NX_TARGETS
  3. 20231016_091352.log
    20231016_091352.log (108.7 KB)

The file (P3768_A04_OrCAD_schematics(base_version).pdf) is official by NVIDIA.
The file (wh-mod-gpu-orin-ia-a_20231016.pdf) is self-made.
P3768_A04_OrCAD_schematics(base_version).pdf (974.2 KB)
wh-mod-gpu-orin-ia-a_20231016.pdf (429.5 KB)

I just ask for the simple block diagram of the peripherals connected to your board rather than the HW schemetics. (just like you shared in 13/Oct.)

Could you point out what’s your custom design for USB different from the devkit?

Thanks for your clarification with the difference.

Could you also help to clarify and state what’s your issue?

I’ve checked you serial console log in 16/Oct., USB function worked as expected.
But there error in screenshot of 13/Oct.

Could you help to capture the failed log when you hit the issue?

During the startup process of my system, there will be no USB error in the serial output, but when I enter the system, when I plug in the mouse or keyboard, there will be an error output on October 13th.

Like the issue I described on October 13th, I can use USB 3.0 devices such as mobile hard drives, but I cannot use USB 2.0 devices such as mice, keyboards, and USB 2.0 USB disk.

Please provide the full dmesg when you hit the USB error.
and also share the dtb file in use. (/boot/dtb/kernel_XXX.dtb on your board).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.