Jetson TK1 - No Video Output

Hi There,
I did flashed my Jetson TK1 to latest version of rootfs and I am not able to boot it now.

I am able to flash new firmware. Process finishes with no error.

Unfortunately after reboot I see nothing just the black screen.
Ethernet cable is connected, orange LED is on but green LED is not blinking.

In WebUI of my router I can see that jetson tk1 did not asked for IP address.

I have usb to serial cable but I am not sure how to use it for troubleshooting.

Anybody has an idea how to troubleshoot and fix this?

Tomas

What was your exact command line during flash?

Was flash from L4T R19.3?

Did you do any kind of apt-get upgrade operation?

Were all operations during flash, including unpacking of files, done as root or sudo?

Is your flash host using a native linux file system, or is it a virtual system such as vmware using a non-native file system?

I followed the steps from latest “Getting started” document.

Yes, i did some apt-get upgrade stuff before flashing this.

All operations were done using the sudo.

Flash host is using native ext4 filesystem on SSD.

Recent X11 packages overwrite some nVidia packages. See:
https://devtalk.nvidia.com/default/topic/775070/embedded-systems/notice-on-apt-get-upgrade-libglx-so-corruption/

Use serial console (115200, 8n1) and see if this checks ok:

sudo sha1sum -c /etc/nv_tegra_release

Also, beware that the getting started guide is somewhat outdated.

I tried to connect using gtkterm but with no luck.

If I type nothing is echoed, there is no output from command i type.

I tried to reflash the device one more time and there was no error.

How you do connect to jetson using serial cable? What program do you use? What are the settings?

Are there any other way how to troubleshoot the device? In the situation when it seems the device is not booting (no ethernet connection) neither serial connection is working?

It’s the DB-9 connector. Use a “null modem” cable to your desktop, or to a serial UART adapter USB cable. Setting is 115200 speed, 8n1. Sometimes there is a setting for flow control which will work on no flow control or with XON/XOFF (I use the latter).

Any serial console program works. I use mostly gtkterm, others are minicom or PuTTY (this latter on windows). Under linux you will need permission for serial port access, so it could mean just using root or sudo on your gtkterm or other program, or perhaps a user with “dialout” group (whatever group covers serial ports).

Debugging would depend on results of serial console connect.