Jetson TX1 How To enable DRM? (About Wayland , AGL)

Hello, I am doing AGL (Automotive Grade Linux) porting on Jetson-TX1.

However, the DRM module could not be found.
I tried to find DRM on Ubuntu pre-installed on Jetson-TX1, but DRM did not exist.

I am using Yocto Layer and Add Unofficial ( I don’t know exactly ) TX1 Layer ( https://github.com/madisongh/meta-tegra )
and I enabled ‘drm’ through ‘make menuconfig’

But loading Failed.How can I enable DRM?
The Log said, “no drm device found”

This is My Log. ( Launch AGL , AGL use Wayland)

root@jetson-tx1:~# /usr/bin/weston-launch --tty /dev/tty1 --user root – --idle-time=4294967
Date: 2017-06-02 UTC
[03:34:31.978] weston 1.11.0
http://wayland.freedesktop.org
Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=1.11.0
Build: 1.10.93-2-g2d825ed configure.ac: bump to version 1.11.0 for the official release (2016-05-31 17:10:40 -0700)
[03:34:31.978] OS: Linux, 3.10.96+, #14 SMP PREEMPT Mon Jun 5 18:42:52 KST 2017, aarch64
[03:34:31.979] Using config file ‘/etc/xdg/weston/weston.ini’
[03:34:31.979] Output repaint window is 7 ms maximum.
[03:34:31.979] Loading module ‘/usr/lib/weston/drm-backend.so’
[03:34:31.982] initializing drm backend
[03:34:31.982] logind: failed to get session seat
[03:34:31.982] logind: cannot setup systemd-logind helper (-61), using legacy fallback
[03:34:31.983] no drm device found
[03:34:31.983] fatal: failed to create compositor backend
failed to restore keyboard mode: Bad file descriptor
failed to set KD_TEXT mode on tty: Bad file descriptor
could not reset vt handling

Hi SuchangKo,

Sorry to tell you that tegra has not provided DRM module in kernel and no clear plan is ongoing now.

We enable DRM-KMS in tegra now. If you want to use X11-less rendering method. Please take a look at our MMAPI samples -08_video_dec_drm.