Jetson TX2 : boot on SD Card

Although this was for TX1 and a few L4T releases before, you may find some useful informations in jkjung’s blogs. It may no longer be mandatory to edit /lib/init/fstab as mentioned at the end.

Hi djm-avalesta,

To be honest I tried so many things to get it working that I won’t be able to tell a correct procedure… I will probably have to repeat the procedure next month so I will do my best to note everything until it works and then share it !

But what I can say for sure is that I removed all rules to boot from eMMC or my SSD.

As for the link that Honey_Patouceul shared, I did not see this one ! It might help even if it is for TX1.

Sorry for not being able to help more than that…

Ok, thanks wbfbr15, you’re working with TX2 like me, right?

I have managed to boot from an ext4 formatted SD card, but now, when I take out the card, it doesn’t boot from eMMC anymore, I get “System Program problem detected”. I didn’t change anything on the eMMC.

Any ideas would be welcome, I’m getting a debug cable made so we’ll see what that says…

How to make a bootable SD card, are there any clear instructions somewhere?
I tried by coping rootfs onto sd card and using to copy dts and kernel and then changing the extlinux.conf but still it boots from the emmc.
What should be the number of partitions on the sd card ? I formatted it ext4.
Can someone please provide step by step instructions on how to make a bootable sd card.
I understand the uboot will still be on emmc.

Hi there, randhawp, I made this work by modifying uboot. Basically, I change the boot order so that mmc1 (mmcblk1p1, the Sdcard) comes before mmc0 (mmcblk0p1, the MMC APP partition). I can give you more details on Monday but you need to download the uboot source from NVidia and get familiar with building it and flashing it to the kernel partition, mmcblk0p26 from memory. Do this once first and make sure the uboot build date has changed when viewing boot-up on the console. Then you can look at making the mods to the boot order.

Thanks. I can compile u-boot but flashing fails. Maybe will look on other parts of the forum, but where in u-boot is the boot order ?

Hi guys,

I’ve faced same issue and solved it by changing root=/dev/mmcblk0p1 to root=/dev/mmcblk2p1 on SD card section of extlinux.conf.

In my case, specifying right name for SD card solved the problem.

You can checkout the name of disks with “Disks” application on ubuntu.

Hope this helps.

Nice! Thanks for your sharing.