Jetson Xavier boot up issue

One of the Jetson Xavier dev kits is not booting up. We shut it down using the terminal and when we powered it back again, the OS is not booting up. We tried to connecting the display and we could not see anything displayed. We then tried to see the boot messages on the micro USB port and see that it is getting stuck in the MB2 stage and not going forward to cold boot. I do not want to lose any data. So, if there is a way to read the contents, I can backup the data and then reflash the OS.
Any guidance here would be appreciated.

Attaching the boot log here for your reference.

xavier_log.log (6.4 KB)

In recovery mode, using an Ubuntu host PC, you can clone the rootfs. You need a lot of disk space on the host PC since it clones both a raw partition (an exact bit-for-bit copy of the partition) and a “sparse” image (smaller because it doesn’t copy the empty space of the filesystem, but not as flexible). Then you can loopback mount the partition and read everything on it. Typical clone if in recovery mode:
sudo ./ -r -k APP -G my_backup.img jetson-agx-xavier-devkit

Note that this would produce both my_backup.img and my_backup.img.raw. It is the latter “raw” file you are interested in. Beware this is an enormous file and will take a lot of time if you try to copy it somewhere else. Creating the clone takes a long time as well.

An example loopback mount if you have empty directory “~me/backup/”:
sudo mount -o loop /where/ever/it/is/my_backup.img.raw ~me/backup/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.