Jetson xavier nx flash nvme success, but boot panic

boot.log (62.4 KB)
flash.log (180.7 KB)
I use the external command to flash xavier-nx nvme, and it shows that the flashing is successful, but the device fails to start. The log is as follows. What is the reason?

Hi liwang54321,

From flash log, it seems you flash with –no-flash flag.
From serial log, it seems stuck causing from kernel panic.

Are you using the devkit or custom board?

Does your Xavier NX could boot up w/o NVMe drive connected?

I use Xavier NX devkit ,–no-flash is automatically added by the script, I tried flash_only but it still fails;
flash.log (32.3 KB)
uart-flash &boot.log (125.4 KB)

There is no problem using sd card

Sorry, --no-flash flag is used for Step 1 to Generate flash packages.

Have you tried to use SDKM to flash into NVMe drive?

and what’s the physical size of your NVMe drive?

1 Like

SDKM is ok, but I want to use a script to flash; ssd is 500gb

Could you help to try the following flash command to flash into NVMe drive?

$ sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_nvme.xml -S 400GiB --showlogs --external-only jetson-xavier-nx-devkit nvme0n1p1

and make sure sector_size="512" and num_sectors="943718400" which is corresponding to 450GiB.

Youd could also refer to the following thread for details
Xavier NX 8G boot issue - #9 by KevinFFF

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.