Jetson Xavier NX Setup Problem for ultralytics repo

Hi there.
My system info:
Jetson Xavier NX(EN715 board from avermedia)
Jetpack version: 4.6
Cuda: 10.2

I have a problem that ı have been facing let me summarize the issue:

  1. As others have mentioned I want to use yolov8 (or yolov5 it really doesn’t matter)within a docker image in nvidia jetson xavier NX. However since my board is one of those avermedia boards I can only get up to jetpack 4.6. So therefore there are a few questions that came up: 1) Since ultralytics requires python>3.8 and the provided docker images work with python3.6.9 is there an alternative way I can use the cuda10.2? What I tried at 1: But it didn’t work I have used pytorch 1.7 cp38 wheel I could see cuda but I have gotten the error of pytorch not compatible with the cuda version(10.2)

By the way I am aware that TensoRRT is a solution but how much control will I have over that?

I have tried many dockerfiles but none of them gave me True on :

torch.cuda.is_available()

I also tried creating a virtualenv with python 3.8 and downloading cuda available version of 1.7 from a wheel and I could see the gpu but trying to get the model on gpu gave me this warning.

model.to(“cuda”)
/home/nvidia/.local/lib/python3.8/site-packages/torch/cuda/init.py:104: UserWarning:
Xavier with CUDA capability sm_72 is not compatible with the current PyTorch installation.
The current PyTorch install supports CUDA capabilities sm_53.
If you want to use the Xavier GPU with PyTorch, please check the instructions at Start Locally | PyTorch

warnings.warn(incompatible_device_warn.format(device_name, capability, " ".join(arch_list), device_name))

I think I have explained what I went through here. By the way I can’t update the jetson nx to a newer version of a jetpack because of the board.

What do you all suggest on this? I am open to trying out everything possible.

Thanks :)

Edit: Please update me if the post isn’t clear I can update it.

Hi,

Please try the container below for a PyTorch package with CUDA support:

Which JetPack 4.6 do you use?
For JetPack 4.6, please try r32.6.1-pth1.8-py3 or r32.6.1-pth1.9-py3.
For JetPack 4.6.1, please try r32.7.1-pth1.10-py3 or r32.7.1-pth1.9-py3.

Thanks.

Thanks for the reply!
Again when I wanted to check your recommendation ( I am using jetpack 4.6)
I get this error when trying to import torch.
OSError: libcurand.so.10: cannot open shared object file: No such file or directory

From the looks of it , I need to be able to check LD Library path since it can’t find the necessary cuda I guess. How can I make sure I export the path right here?

Also this is how I run the container.

> sudo docker run -it --rm --runtime nvidia --network host nvcr.io/nvidia/l4t-pytorch:r32.6.1-pth1.8-py3

By the way this should solve the problem for python3.6.9. But I need python 3.8. Another question I have is will I be able to use cuda with python3.8 in the same container? I can give out some commands to do a build from that container again but what’s the right approach here? Thanks!

Any updates on this @AastaLLL ?

Hi,

We only provide the package with the default Python version.
On JetPack 4 (Ubuntu 18.04), it is Python 3.6.

For other versions, please build it from the source.
The steps can be found in the below topic:

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.