Jetson Xavier torchvision Installation problem

Hi ,
I tried to install pytorch and torchvison on my new jetson xavier, I installed torch sucessfully but when I tried v0.5.0 and v0.7.0 version of torchvision and installing both of them under this step :
$sudo python3 install

Error occured as below:

oserror: cannot open shared object file: no such file or directory

Can someone help me with this?


The error indicates you don’t have a cuDNN v8.0 library.

Do you setup the environment with JetPack?
Could you double check if you have cuDNN v8.0 installed first?


Thanks for your reply. I am new to Jetson Xavier, I have assumed Jetpack includes Cuda and Cudnn in it. Could you explain more detailedly about what to install to run torch and torchvision on Jetson Xavier.

I have used
$ find -name
command to search for cudnn,
The results are

I don’t know if it’s ok to show the right path of cudnn.

If you are using Jetson Xavier NX and flashed the SD card image, then you should find libcudnn under /usr/lib/aarch64-linux-gnu, like shown here:

$ ls /usr/lib/aarch64-linux-gnu/libcudnn*
/usr/lib/aarch64-linux-gnu/           /usr/lib/aarch64-linux-gnu/libcudnn_cnn_train_static.a
/usr/lib/aarch64-linux-gnu/         /usr/lib/aarch64-linux-gnu/libcudnn_cnn_train_static_v8.a
/usr/lib/aarch64-linux-gnu/     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_adv_infer_static.a     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_adv_infer_static_v8.a  /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/           /usr/lib/aarch64-linux-gnu/libcudnn_ops_infer_static.a
/usr/lib/aarch64-linux-gnu/         /usr/lib/aarch64-linux-gnu/libcudnn_ops_infer_static_v8.a
/usr/lib/aarch64-linux-gnu/     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_adv_train_static.a     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_adv_train_static_v8.a  /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/           /usr/lib/aarch64-linux-gnu/libcudnn_ops_train_static.a
/usr/lib/aarch64-linux-gnu/         /usr/lib/aarch64-linux-gnu/libcudnn_ops_train_static_v8.a
/usr/lib/aarch64-linux-gnu/     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_cnn_infer_static.a     /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/libcudnn_cnn_infer_static_v8.a  /usr/lib/aarch64-linux-gnu/
/usr/lib/aarch64-linux-gnu/           /usr/lib/aarch64-linux-gnu/libcudnn_static.a
/usr/lib/aarch64-linux-gnu/         /usr/lib/aarch64-linux-gnu/libcudnn_static_v8.a

Do you see those? If not, did you flash your SD card with the image from this link?

If you do in fact have the libcudnn libraries on your NX, then make sure that the PyTorch wheel you installed matches the version of JetPack that you have installed. For example, the PyTorch 1.7 wheel supports JetPack 4.4 (L4T R32.4.3) and JetPack 4.4.1 (L4T R32.4.4). The PyTorch 1.5 wheel supports JetPack 4.4 Developer Preview (L4T R32.4.2).