K10 has a problem with "large" gridDim.x

I am using a GPU with these parameters

Device 0: “Tesla K10.G1.8GB”
CUDA Driver Version / Runtime Version 5.5 / 5.0
CUDA Capability Major/Minor version number: 3.0
Total amount of global memory: 3584 MBytes (3757637632 bytes)
( 8) Multiprocessors x (192) CUDA Cores/MP: 1536 CUDA Cores
GPU Clock rate: 745 MHz (0.75 GHz)
Memory Clock rate: 2500 Mhz
Memory Bus Width: 256-bit
L2 Cache Size: 524288 bytes
Max Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536,65536), 3D=(4096,4096,4096)
Max Layered Texture Size (dim) x layers 1D=(16384) x 2048, 2D=(16384,16384) x 2048
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Maximum sizes of each dimension of a block: 1024 x 1024 x 64
Maximum sizes of each dimension of a grid: 2147483647 x 65535 x 65535
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 2 copy engine(s)
Run time limit on kernels: No
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Enabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 159 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

If I invoke my kernel like this: kernel<<< 65535, 1024 >>> then everything works fine.
However, if I invoke it like this: kernel<<< 65536, 1024 >>> then it fails in that the kernel does not seem to get invoked.
I would have thought that 65536 is not excessive, as gridDim.x has a limit of 2147483647.

By the way, I can run it with 65536 or more blocks by arranging them in a multidimensional grid (as long as no dimension exceeds 65535).

Any suggestion?

My guess is that you are not passing nvcc the correct flags to compile under CC 3.0. See the Technical Specifications CUDA Compute Capability version table on Wiki: http://en.wikipedia.org/wiki/CUDA#Version_features_and_specifications

Thanks for the pointer. It is very useful in general, but I could not find any description of compiler flags there.
Based on http://docs.nvidia.com/cuda/cuda-compiler-driver-nvcc/index.html
I tried to add -arch=compute_30 -code=sm_30, but that did not seem to make a difference.
What kinds of flags should I be looking for?

That was the flag I was referencing you should add to nvcc, apologies I didn’t explicitly state it. Perhaps someone else can comment on why it’s still not working, that’s my only idea.

Are you error checking the output of your kernel launches? Would be ideal to see what the error is.

I am sorry, I was wrong in my previous reply; those flags do solve the problem.
Thank you very much for your help.