Kafka server did not receive information from the device

**• Hardware Platform (Jetson / GPU)**jetson NX
• DeepStream Version 5.0.1
**• JetPack Version (valid for Jetson only)**4.4
• TensorRT Version

I encountered difficulties when trying to send the recognition results(License plate number) to Kafka.
I have tried to run /opt/nvidia/deepstream/deepstream-5.0/sources/apps/sample_apps/deepstream-test4, and I can receive json messages on the Kafka server.
But after I modified the following files according to deepstream-test4, Kafka did not receive any information.
lp_kafka.txt (6.4 KB) ds_msgconv_lp_config.txt (1.9 KB)
On kafka server, consumer.py refers to Using Kafka protocol for retrieving data from a deepstream pipeline. - #14 by NitinRai
Can you help me see if there is a problem with the file? What should i do?


We are checking this issue internally.
Will update more information with you later.


Thank you for your reply.
Is there any progress on this issue? Do you have any suggestions for me? I really look forward to your reply.


Sorry that we are still checking this issue.
Will share more information with you later.



Thanks for your patience.

How do run the lp_kafka.txt file?
Please noted that you will need to run it with deepstream-test5-app rather than deepstream-app.

We can run your configure successfully (consumer can receive message).
Would you mind to double-check it?


1 Like

Yes, you are right.
I run it with

and then, I received massage.
But I don’t receive the LP message.

I hope receive the licence plate number, too.
Do you have any suggestions for this problem?
Thanks very much!

solve it!

deepstream-test5-app -c config.txt -m 1

Thanks for the feedback!
Good to know it works now.