Kernel Recognizes 4th GPU but NVIDIA Driver Doesn't

I put a 4th GPU on one of my motherboard’s PCIe x1 slots using a riser and when I start up Ubuntu 17.04, it seems like the kernel recognizes the 4th GPU because all 4 show up in lspci. However, when I run nvidia-smi, it only recognizes three. When I run dmesg | grep nvidia, I get:

[ 1.010904] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[ 1.010975] [drm] [nvidia-drm] [GPU ID 0x00000200] Loading driver
[ 1.011021] [drm] [nvidia-drm] [GPU ID 0x00000300] Loading driver
[ 1.011321] [drm] [nvidia-drm] [GPU ID 0x00000500] Loading driver
[ 4.949631] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 240
[ 7.718236] nvidia-modeset: Allocated GPU:0 (GPU-4924e62f-ac32-93ac-ef48-3d96671d6455) @ PCI:0000:01:00.0
[ 8.370621] nvidia-modeset: Allocated GPU:1 (GPU-91f82e1c-0a3d-132c-4c94-28b3395c7e7e) @ PCI:0000:02:00.0
[ 9.097813] nvidia-modeset: Allocated GPU:2 (GPU-3d1dace1-cebe-b66d-47a8-0e112ecfb029) @ PCI:0000:03:00.0

I’ve been using Linux for a bit, but I’m not a superuser. If I know the address of the missing GPU (PCI:0000:05:00.0), is there a way for me to manually do what nvidia-modeset is doing for the other three GPUs during start-up? Thanks.
nvidia-bug-report.log.gz (271 KB)

The snippet from your dmesg is too short to tell what’s happening, probably initialization fails inbetween. Please run as root and attach the tar.gz file is creates to your post.

I attached it to my original message. I didn’t know about that script beforehand. I found something in the log where it said it failed to initialize GPU3.

[ 7.153] (EE) NVIDIA(GPU-3): Failed to initialize the NVIDIA GPU at PCI:5:0:0. Please
[ 7.153] (EE) NVIDIA(GPU-3): check your system’s kernel log for additional error
[ 7.153] (EE) NVIDIA(GPU-3): messages and refer to Chapter 8: Common Problems in the
[ 7.153] (EE) NVIDIA(GPU-3): README for additional information.
[ 7.153] (EE) NVIDIA(GPU-3): Failed to initialize the NVIDIA graphics device!
[ 7.153] (II) NVIDIA(GPU-3): Deleting GPU-3

The card fails on driver init, so either the card or the slot is broken. Swap cards and see if the error changes or stays.

I updated the BIOS and that did it. Thanks! I assumed that since the card was showing up in lspci, everything must be okay with the BIOS and kernel, but turns out that wasn’t the case.