Laptop turns OFF,nVidia GPU seems to be the issue - please HELP

Hello Guys

I have Dell 7577 laptop with i5 7300HQ CPU and 1050 4GB model GPU.It has 130W AC adapter and 56Wh battery life.

Now i noticed issue with the laptop that whenever i would run intensive apps on the battery only laptop would after short period of time shut down on its own.

At a time i did not understood that components can’t exceed their power level,that each not just CPU but GPU state and other components(sometimes may be relevant)have their own power level set per specific state,so running on battery would mean lowering nVidia GPU levels.

Issue with this is in that nVidia control panel have Auto,Performance and Adaptive level while none of these seems to specifically stuck specific speeds regardless of the app needs GPU scale to the higher level.

How can i lower these level in the config or unlock them inside nVidia control panel software if possible,or should i set up cards on such way that Intel works when on battery and nVidia only on AC.

Which solution would be better and why or would they both technically be an option to set up?

Some laptops have bigger batteries so naturally higher component power level can be reached but still i would like to know more about this topic because regardless of downclocking CPU,GPU is the one that takes majority of power so i really need to be able to tweak GPU.

I am using Latest Xubuntu LTS release at the moment 18.04.1

So my interest is to have 2 different profiles,1st for AC and 2nd for Battery which would change automatically depending on the input live,without laptop shutting down,need for logging out or restart.

Thanks for the help in advance.

Regards

Also let me add that i run proprietary driver version 396.54.

Thanks

Installing acpid should keep the gpu at lowest performance when on battery.

Acpid is installed by default and it doesn’t seem to work.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Here is the attachment
nvidia-bug-report.log.gz (653 KB)

Looks more like a cooling problem.
When you start nvidia-settings, power-mizer pane, then pull the ac plug, does it show ‘battery’ for power source? Furthermore, does it stay on performance level 0, even when you start something like glxgears? How does the temperature develop? How much time is it in general until the system shuts down?

Once you pull off the ac plug it does display battery status.

Powermizer goes from 0 to 2 but as you run more intensive 3D acceleration it will shut down almost after few seconds.

It can function normally until specific power level which i assume is due to battery strength.

This is why i created second board where i asked how i can change the powermizer level and cooling preferably.

https://devtalk.nvidia.com/default/topic/1045355/nvidia-powermizer-need-help/#5304084

If on battery i would like to stick it to lvl 1 or lvl 2 assuming that lvl 1 would probably be the right choice.

How do i do that?

Thanks

The desired behaviour is a standard function of the driver. Pull the plug and the performance level gets nailed to 0. Since this doesn’t work on your system, that’s a driver bug.
Achieving this manually is not feasible in a useable manner since changing the performance setting requires a reboot or at least an Xserver restart so you could as well simply switch to intel.
Nevertheless, the notebook should never shut down when stressed while on battery, that’s a hw failure, I would RMA it if possible.
BTW, anything noticeable regarding temperatures while on battery?

The previously working setting for this was

Option		"RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3;"

Though this was reported to not work anymore in newer drivers.

The registrydwords can be either set in xorg.conf or in a file in /etc/modprobe.d, e.g. /etc/modprobe.d/99-nvidia-registry.conf

options nvidia NVreg_RegistryDwords="PowerMizerEnable=0x1; PerfLevelSrc=0x2233; PowerMizerDefault=0x3"

and run
sudo update-initramfs -u
then reboot.

https://www.dell.com/community/Inspiron/Dell-7577-shut-down-on-battery-when-using-nvidia-GPU-Linux/td-p/6189738

That is my thread there on the forum.

Once completely resolved ill update it there.

Thank you this works.

However i would like to test more.

How would i be able to set AC and battery mode in the config individually and to set up each of the levels individually?

For example i would like to set lv2 on AC and lv 1 on battery,what would be the parameters for each?

On the topic of xorg.conf for some reason i can’t have anything in the config file,it has to be blank in order for OS to boot.

I did solved issue partially by installing xorg.dev package but still,as soon as i run nvidia-settings and once default config is written,after reboot it just wont work.

I am asking this as i am not sure how to set up fan control.

Sorry for bugging you,it would help a lot.

Thanks ;)

I’m surprised that it works for you. For insight into the individual parameters please use the forum’s search function, it’s been chewed through alot. YMMV.
Regarding fan control, look up ‘coolbits’ https://download.nvidia.com/XFree86/Linux-x86_64/384.98/README/xconfigoptions.html, not available on every nvidia gpu, only fixed values if possible.

Still, this is fixing broken hardware by software. That piece sure was expensive, you should RMA it.