Problem with performance nvidia 1050m

Hi friend’s, i’m new user of this laptop with a video nvidia.

My problem is this:

When i use my laptop with the AC power my performance is very low on my games.If unplug the AC power have a best performance.

I do test with diferent distributions of Linux, for example Arch Linux, Fedora and Ubuntu.

Actually i have Ubuntu 18.04.1 LTS, driver version nvidia 390.48 and my game for test is DOTA 2 and Tomb Raider.

please help me,i did not found the solution for this problem
nvidia-bug-report.log.gz (107 KB)

That’s odd, should be the other way around. Please put the gpu under load, run as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.
One thing to check in advance is whether you have the acpi daemon (acpid) installed, if not, install it.

Thank’s a lot for your answer, is very odd, how i can set the GPU under load?
the bug report result is attached in my first post now. ACPID is correctly installed.

Simply run a game or an Unigine demo in windowed mode while running
There’s nothing unusual visible in the logs, besides you’re running an older driver. Can you use the ubuntu graphics ppa, install nvidia-396 and the create the log while having load on the gpu?

OK, in this post i do attach the log, first open my game “DOTA 2”, next run the nvidia bug report with the power pluged.

My drivers is update with the PPA comment.
nvidia-bug-report.log (752 KB)

In this secound post i do a equal operation but without power connected.
nvidia-bug-report.log (757 KB)

Ok, now the bug surfaced. While on AC, the gpu simply refuses to take more than 50% load while on battery, it takes 100% load. I’ve seen that before but don’t think that has ever been resolved.
Two things you could try, use
as kernel paramter, if it doesn’t work, it should at least get rid of tearing. Second, see if disabling acpid is somehow helping.

Yes, your first idea is for resolve the tearing issue but no the performance problem, i do test now and does not work.

The secound solution does not work, i do stop and disable with:
systemctl disable acpid
systemctl stop acpid

after of that reboot and the service reborn. XD
Now go to uninstall the service.

Well, i tried the las resource without solución. :(

Then my out is go to windows?

You can only test any new driver that gets released and report in this thread until nvidia picks this up and fixes it.

Well, i do test with 410.57 drivers and equal error.

Thank’s for the help friend.

Might help to send a bug description with a reference to this thread and the both logs to

Ok, now send a new mail with one explication and attach the LOG.

well the mail is sended now. @generix, one question:

Can you show me where see you the performance on the files attached?

It’s in the output of nvidia-smi -q
On battery:

        Gpu                         : 100 %
        Memory                      : 66 %

On AC:

        Gpu                         : 51 %
        Memory                      : 26 %

Today Nvidia team answer me the email, they are saying first show the problem to the manufacturer “Dell”.

Dell say me the support is only for Windows product, now i am waiting the next answer of Nvidia respect to the problem.

Just out of curiosity, can you check if using the kernel parameter

acpi_osi=! acpi_osi="Windows 2009"

somehow changes the situation?

Hi generix, yes, in the past i did the test with that tweaks but without change.

BTW, does your system properly suspend and resume without the acpi_osi parameters and does that have an effect?

Hi generix, i did a test with the configuración sugested but with " and ’ and the error is equal.

The suspend and resume is equal.