Linux suspend problem

I am using Nvidia properitary driver on Linux Arch x64 with GNOME 3.26.2. My GPU: GTX980

When i suspend and wake up my PC the performance gets really poor, i managed to get the suspend to work one time following this:

https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Poor_performance_after_resuming_from_suspend

but its not working anymore, the suspend is broken again.

Help me please !

Having the same issue, supprised it hasent been addressed by the arch wiki community yet, as its been about a month so far and makes linux almost un-usable on my main system.

The old kernel module load options NVreg_RegisterForACPIEvents and NVreg_EnableMSI seem to have been removed, this was the only (known) way to prevent waking from suspend causing massive lag across the entire DM.

Another possible angle to try and fix it from is preventing the ACPI power management from varying power to PCIe devices, I think, however this is not an overly optimal solution, and not particularly well documented in terms of how to achieve it.

They need to update the fix aricle, its not working due to updates :-/
I`ll email them to check it, you should od it as well

Please run nvidia-bug-report.sh as root when issue hits and attach the tar.gz file it creates to your post.


Here.

No noticeable differences, gpu running at the same clocks as before.
Where is this performance loss noticeable, desktop, games?
Maybe install and start acpid.

\

Acpid does NOTHING.

Ok, some things to check:
Does top display something eating your CPU?
run
watch -n1 cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq
then move around a window and see if it scales up properly.
Does restarting/zapping X put it back to normal operation?

I checked today and gaming performance is NOT affected.
And the gpu is at normal load, its not consumed by anything more than usual

Maybe you’re just seeing the mutter-nvidia-vsync bug.
Add the line

CLUTTER_VBLANK=none

to /etc/environment
and reboot.

Adding that caused boot issues, i wasnt getting anything other than the grey background from GDM, tried loggin using other method but gnome-shell refused to work, i undid the fix you provided through livecd

Yes , sorry, Gnome/Mutter is now completely bugged
https://bugzilla.gnome.org/show_bug.cgi?id=792643
You could have just switched to VT and log in normally.
Due to the current bugs with Gnome and the Nvidia driver it’s just hard to debug your problem.

But my screen wasnt blank, i had the cursor, and the gdm background

Yes, that’s excactly the issue. mouse pointer is moveable, you have a picture which is not updated.

Can I expect Nvidia or Gnome devs to fix it ?

Nvidia has nothing to do with it, it’s a plain Gnome issue. I’d rather put my hopes into Ubuntu devs since they switched to Gnome as their main DE. Gnome devs are rather uncooperative to fix even simple things.

But i am using Arch, not Ubuntu. How would Ubuntu devs modify Gnome for all distros ?

And why the fix from archwiki worked ? (But are not working now)

Just think I should jump in again and reiterate that I have the exact same issue (as detailed for older versions of the Nvidia drivers on the arch wiki page linked), and run i3wm with Arch.

The problem does not exist on my laptop with a near identical arch setup but without NVIDIA drivers.

So its not ENTIRELY Gnome`s fault

  • The bug that I was linking to is a Gnome bug.
  • The cause of your performance problem is yet unknown
  • The symptoms of your performance problem are also unknown, you failed to properly describe them, even when specifically asked.
  • Due to bugs with Gnome it is currently not possible to find the cause when using Gnome.
  • validifyed is using i3wm, yet was just saying ‘me too’.
    What exactly is the problem, what symptoms?