Latest driver causing multiple symbol definition error


I just updated my driver from 465 to 470 and am now getting a multiple definition error:

Error: Symbol '__miss__radiance_1_0xc1f0da79cbec1bee' was defined multiple times. First seen in: '__miss__radiance_and_1_more_2611075355310804029'
Error: Symbol '__miss__shadow_1_0xc1f0da79cbec1bee' was defined multiple times. First seen in: '__miss__radiance_and_1_more_2611075355310804029'

Those two functions are defined a single time in a file with no other definitions in it and it is not included anywhere else so I’m not entirely sure why I’m running into this. I also have which has 2 closest hit programs in it (which are compiled identically to the miss module), but I’m not seeing an error for those?

This was working fine with driver 465 so I’m trying to understand if this is a driver issue or if the updated drivers just surfaced an underlying issue that I had.


That can happen when the application creates multiple modules with identical PTX and those get linked together.
Check that each *.ptx file is only used by one module during your pipeline creation.

If that’s not it, please provide more information about your system configuration and a minimal and complete reproducer showing that problem.
OS version, installed GPU(s), VRAM amount, display driver versions, OptiX (major.minor.micro) version, CUDA toolkit version (major.minor) used to generate the input PTX, host compiler version.
Especially important in such cases are the exact version numbers of the drivers which worked and which didn’t.

Hi @droettger ,

Yes, this was the issue. I guess there was some difference between the drivers where it still worked/passed before, but doesn’t on the newer ones.