latest stable driver 310.32 wont compile on stable kernel 3.7.6, 3.7.7, 3.7.8

I spits out that generic “ERROR: If you are using a Linux 2.4 kernel, please make sure blah blah blah…” message. From what I’ve read, apparently the problem is kernel/conftest.sh checking for hardcoded kernel versions (at line 1705-1706). If you manually unpack the nvidia installer .run file and change line 1706, it will compile and run just fine.

But, it sort of sucks that users have to do that to use the last few stable kernels with the latest stable driver. Hopefully this issue will be resolved in a way where we won’t be facing it again after a few more kernel releases.

Using this patch for > 3.7.5 - http://www.meyithi.com/pubdock/linux-3.7.patch
This patch is also available for 3.8 - https://gist.github.com/anonymous/4957168

Good links Meyithi, thanks for posting! Hopefully its fixed in the next beta driver at the very least.

Actually 313.18 drivers compile just fine under Linux 3.7.

Upto 3.7.5 sure, after that there are problems. The first patch I posted explains why.

I’m not sure what you’re talking about, I’m on 3.7.6 vanilla without any patches to the kernel or NVIDIA drivers and everything works.

https://bugs.gentoo.org/show_bug.cgi?id=447566
https://bbs.archlinux.org/viewtopic.php?pid=1227537
https://forums.geforce.com/default/topic/528955/geforce-drivers/nvidia-linux-x86_64-310-32-and-kernel-3-7-6/
http://crux.nu/bugs/index.php?do=details&task_id=885&project=1&order=status&sort=desc
https://bugzilla.novell.com/show_bug.cgi?id=795837

Want more links? Not sure why you are being so dismissive but can all of these people be wrong?

Hm, I see, then why does it work for me? ;-)

because you’re either using a distro-prepared kernel or are building in-tree (which is frowned upon).

Just attempted installation of the 313.18 drivers under fedora 3.7.6 and I can assure you it most definitely does not work out of the box.

Creating a link to the header.h file allows successful installation of the driver, per the instructions at this site:
http://rglinuxtech.com/?p=639

On a separate note, this bulletin board is in horrible need of an upgrade. Requiring entry of the captcha code prior to a post based form validation (on new user registration) is obnoxious, if not outright enraging.