libnuma saying no version information available

Hi,

I have a code that when I compile and run it on my Mint 18 machine (based on Ubuntu 16.04) it works fine.

For some reason, when I try to compile and run it on my Ubuntu 16.04 system, I get the following warnings:

/usr/local/pgi/linux86-64/16.10/lib/libnuma.so.1: no version information available (required by /usr/lib/x86_64-linux-gnu/libhwloc.so.5)

The code seems to run anyways but what is this? Is this a problem?

Teh only major difference between the systems (both are using PGI 16.10) is that the Ubuntu system is a dual-socket CPU system and the Mint system is single-socket.

  • Ron

Hi Ron,

Because our OpenMP runtime library links against libnuma, and that not all systems have libnuma installed, PGI ships a dummy libnuma library. This looks like you have your LD_LIBRARY_PATH set to include PGI’s library directory and another application, such as numactl, is picking up the dummy library.

The PGI installer should make “libnuma.so*” links to the system /usr/lib/libnuma.so* if they exists but may have failed for some reason. If this is the case, then you can fix this warning by either removing the “libnuma.so*” files from the PGI library directories, or making them a link to system libraries.

If you don’t have libnuma installed on the Ubuntu system, then you might consider installing it and then making the above adjustments.

  • Mat

Dear Mat,

at least for 18.10, these symlinks are only instructed to bend to the system libnuma, if Open MPI should also be installed. If one selects not to install the shipped Open MPI package, than the symlinks always point to the dummy libnuma.

Best,
Bert